17 Turbo toe/camber problems - Polaris RZR Forum - RZR Forums.net
Wheels and Tires For discussion of wheels and tires

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old March 31st, 2017, 07:48 AM Thread Starter
 
wolfe0311's Avatar
 
My RZR: 2017 Turbo xp
Member #65781
Join Date: Feb 2014
Location: Bruceton Mills, WV
Posts: 45
Garage
Feedback Score: 0 reviews
View wolfe0311's Photo Gallery(0)
17 Turbo toe/camber problems

Brand new 2017 turbo, just installed the orb high clearance radius rods and msa wheels with 30" motoclaws. Problem is when I got them installed the passenger side is setting funny. It appears to have a lot of lean from top to bottom and also appears to be toed in front to back. I understand they have a sight bit of lean but the drivers side looks fine. Never had any problems like this on my 151k. I adjusted the radius rods off of the stock ones and they are dead on from the stockers. Not sure what this could be. any help is appreciated. I attached a pic for reference.
wolfe0311 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old March 31st, 2017, 07:54 AM Thread Starter
 
wolfe0311's Avatar
 
My RZR: 2017 Turbo xp
Member #65781
Join Date: Feb 2014
Location: Bruceton Mills, WV
Posts: 45
Garage
Feedback Score: 0 reviews
View wolfe0311's Photo Gallery(0)
Re: 17 Turbo toe/camber problems

Pic
Attached Thumbnails
Click image for larger version

Name:	rzr tires1.jpg
Views:	33
Size:	49.4 KB
ID:	406361  
wolfe0311 is offline  
post #3 of 4 Old March 31st, 2017, 08:16 AM
Premium Member
 
triton5150's Avatar
 
First Name: Adam
My RZR: 2015 RZR 1000XP4(sold). 2017 XPT4
Member #73248
Join Date: Oct 2014
Location: Clovis Ca
Posts: 3,542
Garage
Feedback Score: 1 reviews
View triton5150's Photo Gallery(0)
Re: 17 Turbo toe/camber problems

I would say readjust the right side. Maybe it was like that and you never noticed?
triton5150 is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old March 31st, 2017, 08:50 AM
 
PaulK's Avatar
 
First Name: Paul
My RZR: 17 XP Turbo
Member #34432
Join Date: Jan 2012
Location: Peoria, Az
Posts: 1,303
Feedback Score: 2 reviews
View PaulK's Photo Gallery(2)
Re: 17 Turbo toe/camber problems

I have the same issue on my 14 1k

Have read many threads on hear about this passenger side only issue???

have even gone so far as to replacing trailing arm with same result

finally ended up shimming the bearing carrier to trailing arm with washers to get it close but still not like the driver side

Last edited by PaulK; March 31st, 2017 at 08:54 AM.
PaulK is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris RZR Forum - RZR Forums.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2017 XP Turbo Products! Bikeman Performance Bikeman Performance 7 March 18th, 2018 09:05 AM
New turbo problems 07turbo RZR XP Turbo 15 June 2nd, 2017 08:54 PM
Turbo burning oil IBEW1464 Forced Induction 4 April 12th, 2017 10:17 PM
Turbo or Turbo rzr? sledhead21 RZR XP 1000 27 January 27th, 2016 12:03 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome