Polaris RZR Forum - RZR Forums.net banner
1 - 11 of 11 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
this noise or i should say noises just started ,the belt break in was done by the book not hot rodded or abused in any way during the break in period .just 40 miles on . it back at the dealer has anyone ever had anything like this happen .had my wife drive and i was holding the cell phone thats why you see the finger ...sorry
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
It almost sounds like an issue I had. The secondary was jammed and would not fully close on deceleration, leaving the belt loose enough to contact the housing.
thanks , what did you do to fix it ? i will let you know what the dealer says when they are done...i am hoping they can figure it out as i provided them with the video
 

·
Premium Member
Joined
·
1,436 Posts
thanks , what did you do to fix it ? i will let you know what the dealer says when they are done...i am hoping they can figure it out as i provided them with the video
Clutches were end of life anyway. Replaced with new.

Hopefully, it is something simple and not internal trans. Good luck.
 

·
Premium Member
Joined
·
1,422 Posts
@chelan75
I have that ongoing issue on a 2019 RZR in my shop trying to figure it out. I did swap clutches off a new machine and still did it- Changed belt from my spare to a brand new OEM belt no luck
Have ran with the clutch cover off still did it - went completely through both clutches with no issues, so that did not point at the trouble. Idle bearing is 100%

I have a Mech friend that works at the local Polaris dealer and he is scratching his head also.
I have seen where on the output shaft from the tranny on the secondary get's wore from the bushing gets wore and eats on the OD of the shaft and made some weird clutch noises and replaced that shaft, and all was good- but this, as your is making a totally different noise.
Power braked the machine and still does it

Does your machine make that racket till about 8 MPH and then stop? This one is and then stops, when the primary fully disengages.
As you only on deceleration and starts up around 20mph till about 8mph
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #6 ·
@chelan75
I have that ongoing issue on a 2019 RZR in my shop trying to figure it out. I did swap clutches off a new machine and still did it- Changed belt from my spare to a brand new OEM belt no luck
Have ran with the clutch cover off still did it - went completely through both clutches with no issues, so that did not point at the trouble. Idle bearing is 100%

I have a Mech friend that works at the local Polaris dealer and he is scratching his head also.
I have seen where on the output shaft from the tranny on the secondary get's wore from the bushing gets wore and eats on the OD of the shaft and made some weird clutch noises and replaced that shaft, and all was good- but this, as your is making a totally different noise.
Power braked the machine and still does it

Does your machine make that racket till about 8 MPH and then stop? This one is and then stops, when the primary fully disengages.
As you only on deceleration and starts up around 20mph till about 8mph
always on deceleration under 20 mph only stops when i stop or am at a crawl but if your going over 20 mph i dont hear it. they have had it for 5 days now and havent recieved a call so i hope they can fix it or i wont be taking it back home as its brand new with only 40 miles .thanks for the information and if you find out anything please let me know and ill update this as i find out more
 

·
Premium Member
Joined
·
1,422 Posts
The one I am working on has 3,000 miles and non boss secondary- it has the team conversion. When I tossed on a boss secondary it didn’t make a difference.
Just started doing it about 3 rides ago

I noticed today while running it on black top it seemed to lock up only the left rear for just a second to make the tire barking sound -
I check for belt slip cause seemed to point to that but nothing on the clutches or indicated on the belt .
I am doing all this with the belt cover off.
Have it in my shop with the rear tires off and rear in the air. Going to try to replicate it this way cause it’s way to unsafe with tires on amd wobble at 20 mph 😳
Let me know if your dealer tells you anything
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #8 ·
The one I am working on has 3,000 miles and non boss secondary- it has the team conversion. When I tossed on a boss secondary it didn’t make a difference.
Just started doing it about 3 rides ago

I noticed today while running it on black top it seemed to lock up only the left rear for just a second to make the tire barking sound -
I check for belt slip cause seemed to point to that but nothing on the clutches or indicated on the belt .
I am doing all this with the belt cover off.
Have it in my shop with the rear tires off and rear in the air. Going to try to replicate it this way cause it’s way to unsafe with tires on amd wobble at 20 mph 😳
Let me know if your dealer tells you anything
i will as soon as i know ,thanks for you information !!
 

·
Premium Member
Joined
·
1,422 Posts
i will as soon as i know ,thanks for you information !!
So what is that whistling noise at the end of your video?

I adjusted the transmission cable to make it good and spot on- did nothing( just thought it was not staying in gear 100% on deceleration)
Will for sure do the motion with no wheels on it -let ya know.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #10 ·
So what is that whistling noise at the end of your video?

I adjusted the transmission cable to make it good and spot on- did nothing( just thought it was not staying in gear 100% on deceleration)
Will for sure do the motion with no wheels on it -let ya know.
the whistling noise is from the belt / clutch area . i have no idea what is making all that racket.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #11 ·
the dealer called and said that it was a bad belt ,somehow it was stretched ???clutch was removed and inspected they said it was the belt was hitting the cover so i will find out when i pick it up in the morning and drive it myself.i dont know much about the clute/springs or belts so can a belt stretch?
 
1 - 11 of 11 Posts
Top