Polaris RZR Forum - RZR Forums.net banner

1 - 18 of 18 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter #1
was riding today and my 09 rzr quits running if u let off gas...go to start and unless u give it gas it wont start and it wont idle...i started with a reall rough low idle then by end of day it would not idle at all...air filter is clean...my buddy has a rzr a rzr s and now a rzr 4 which is doing the same thing ...he said his all have done it and the fuel pump is starting to go bad...is there a way to check it..ne suggestions...hate to buy pump if thats not the problem
 

·
Registered
Joined
·
223 Posts
was riding today and my 09 rzr quits running if u let off gas...go to start and unless u give it gas it wont start and it wont idle...i started with a reall rough low idle then by end of day it would not idle at all...air filter is clean...my buddy has a rzr a rzr s and now a rzr 4 which is doing the same thing ...he said his all have done it and the fuel pump is starting to go bad...is there a way to check it..ne suggestions...hate to buy pump if thats not the problem
Temporarily connect an old oil pressure gauge onto the fuel line to where you can monitor it while driving, if need be, pressure should be 58 psi whether it's at idle or full throttle.

If that's not it, the T.P.S. may be out of adjustment
 

·
Registered
Joined
·
273 Posts
was riding today and my 09 rzr quits running if u let off gas...go to start and unless u give it gas it wont start and it wont idle...i started with a reall rough low idle then by end of day it would not idle at all...air filter is clean...my buddy has a rzr a rzr s and now a rzr 4 which is doing the same thing ...he said his all have done it and the fuel pump is starting to go bad...is there a way to check it..ne suggestions...hate to buy pump if thats not the problem
Hate to say it but when many RZR's don't want to idle it's low compression which isn't as noticeable at higher rpm's. Run a leak down test just to be sure the top end is in good shape.

Eli
 

·
Registered
Joined
·
54 Posts
Discussion Starter #6
ok fuel pressure is 39 psi and on compression test front was 165 psi and back was 162 psi all these numbers are within the specs stated in my service manual...the t map couldnt find it unless u meant the t bap sensor...engine breather hose is clear ne ideas...just get that sensor and try that??
 

·
Registered
Joined
·
13 Posts
My 2010 did the same thing it had gotten dust past filter and all I did was clean the intake and sensor in the intake tube and it ran great right away. So I put a snorkel with a pre filter asap and haven't had a problem since.
 

·
King of crash!
Joined
·
31,882 Posts
was riding today and my 09 rzr quits running if u let off gas...go to start and unless u give it gas it wont start and it wont idle...i started with a reall rough low idle then by end of day it would not idle at all...air filter is clean...my buddy has a rzr a rzr s and now a rzr 4 which is doing the same thing ...he said his all have done it and the fuel pump is starting to go bad...is there a way to check it..ne suggestions...hate to buy pump if thats not the problem
Temporarily connect an old oil pressure gauge onto the fuel line to where you can monitor it while driving, if need be, pressure should be 58 psi whether it's at idle or full throttle.

If that's not it, the T.P.S. may be out of adjustment
bad psi their its not 58 psi that is to high 38 psi is normall for a rzr
 

·
Registered
Joined
·
54 Posts
Discussion Starter #18
i work out of town all week so tonite i finally got a chance to do some work on the rzr....i talked to a mechanic and he said since i didnt have a check eng light on my throttle body just needed cleaned....so i cleaned it now it starts right up without using the gas but dies in a few seconds ...and now check eng light is on code 22 so im going to buy that tool to adjust the tps and hopefully that does it...
 
1 - 18 of 18 Posts
Top