Polaris RZR Forum - RZR Forums.net banner

1 - 8 of 8 Posts

·
Registered
Joined
·
272 Posts
Discussion Starter #1
You know that thing on the front of the cab on the passenger side that the winch gets electricity from. Well i also have a set of lights running off the same posts. Never an issue until this week end when i needed the winch. Winch doesn't work. Figured it was the controller. Then when it got dark, I tried to turn the lights on. Nada. So that told me that maybe it's a fuse. I checked. All good. What am i missing? Battery connections are tight
 

·
King of crash!
Joined
·
31,882 Posts
get a volt meter and see if you have battery volts at the conection...clean all conections...sometimes tigh isnt enought if its dirty it wont make a good conection...and as said also ck grounds... a volt meter will tell you if its getting juice but be safe clean all of them...
 

·
Registered
Joined
·
272 Posts
Discussion Starter #4
used volt meter. There is power coming from the battery to that box. No power coming out. All terminals are clean. Could the box be bad?
 

·
King of crash!
Joined
·
31,882 Posts
used volt meter. There is power coming from the battery to that box. No power coming out. All terminals are clean. Could the box be bad?
how do you have the power going to your lights? is it on the same terminal as the power from the battery or were you using the box as a switch???

if power to the box and lights is same terminal your lights should work...
 

·
Registered
Joined
·
272 Posts
Discussion Starter #6
Made sure all the posts are clean. Forgot that my horn is connected to the same terminals. The horn works. I think the winch's controller is at fault. Time for a wireless. Also I think that the lights are a separate issue. the switch maybe. They are cheap switches. Haven't precisely tracked that issue yet but that's next.
 

·
Registered
Joined
·
2,149 Posts
That "black box" is known as the contactor, I would free-spool the wire, cable out a bit and jump the terminals (the two that go to the winch, with the positive lead to the contactor) the winch should go out on one and in on the other, if it doesn't the contactor is bad. There is a replacement on E-bay made by a three letter company (I think KDS) that sells for about 25-30$ that is a bolt on but requires the small wire connectors to be replaced,
John
 
1 - 8 of 8 Posts
Top