Polaris RZR Forum - RZR Forums.net banner
1 - 16 of 16 Posts

·
Registered
Joined
·
286 Posts
Discussion Starter · #1 ·
Just wondering if others are having issues or if im just a little slow. I bought a muti angle mounting unit, when I mount the gopro housing unit it will not tighten enough to hold the gopro in place. Is it just me or is there a trick to it?
 

·
Registered
Joined
·
1,737 Posts
GoPro mount or aftermarket? Are you using the short thumbscrew in the camera housing to mount location? The short one hits the case and you won't get it very tight.
 

·
Registered
Joined
·
286 Posts
Discussion Starter · #3 ·
GoPro mount or aftermarket? Are you using the short thumbscrew in the camera housing to mount location? The short one hits the case and you won't get it very tight.
It is a after market mount made by utv inc. the mount comes with its own screw to attach the go pro to it but i cant tighten it enough to keep the gopro secure?
 

·
Banned
Joined
·
904 Posts
Which tube are you using to mount it to? You may be mounting it to a tube thats is to small for the mount. Try moving to a different location and see if you have the same issue.
 

·
Registered
Joined
·
333 Posts
There are two different size tubing on a stock cage, 1 1/2" which is the bar behind the seats and 1 3/4" which makes up most of the rest of the cage. I have the UTV Inc. 1 3/4 mount which I think is the most common and I mount mine on the top front bar and reverse the gopro to shoot upside down. Works great!
 

·
Registered
Joined
·
286 Posts
Discussion Starter · #6 ·
There are two different size tubing on a stock cage, 1 1/2" which is the bar behind the seats and 1 3/4" which makes up most of the rest of the cage. I have the UTV Inc. 1 3/4 mount which I think is the most common and I mount mine on the top front bar and reverse the gopro to shoot upside down. Works great!
Im not having problems mounting it to the rzr. Im having troubles mounting the gopro camera housing to the utv inc. mounting hardware. the plastic housing unit that the gopro fits into will not tighten enough to their mounting hardware to stay in place. I tighten as much as I can with the hardware they provide but it still doesnt hold the housing unit in place enough. was wondering if anyone had this unit and experienced the same issues.
 

·
Premium Member
Joined
·
1,418 Posts
Mine works great...I had it powder coated to match the cage so it is actually tough to get the case in the slots and does not require much pressure to hold it in place

have you tried a new case or have a friend that has one you can try....may be that is worn out as the go pro roll cage mount is plastic so it has some flex.....?????????

you can see it in my pics
 

·
Registered
Joined
·
813 Posts
My UTVINC mount works good.Try using the screw that came with the GoPro.......the one with the black handle end thingy.
 

·
Premium Member
Joined
·
16,003 Posts
i would give utv inc a call monday
maybe take some pics for them guys to look at,
i,m sure its something simple that can be solved
 

·
Registered
Joined
·
3 Posts
I have a HackHD mounted on my front bumper area permanently and connected to my battery. GoPro is awesome to mount around but since I mainly use it on my RZR I went this route since its more than half the price of the GoPro. I can borrow my friends GoPro when I got snowboarding.
 

·
Registered
Joined
·
59 Posts
I have the same problem with mine.
I can't tighten the mount enough at the camera attachment point to hold it upright. For a short term fix I simply moved the camera mount over 1 ear so it sits on the edge instead of in between.
In fairness to UTV, i just recieved the mount Friday evening so I have not called to discuss the issue with them yet.
 

·
Registered
Joined
·
286 Posts
Discussion Starter · #15 ·
I have the same problem with mine.
I can't tighten the mount enough at the camera attachment point to hold it upright. For a short term fix I simply moved the camera mount over 1 ear so it sits on the edge instead of in between.
In fairness to UTV, i just recieved the mount Friday evening so I have not called to discuss the issue with them yet.
Good to know that is not only me. Let me know if you figure something out.
 

·
Registered
Joined
·
815 Posts
Are you guys talking about not getting the camera housing tight enough to the UTV Inc mount that the housing will move?

I had that issue, but i just removed the plastic thumb screw cover for the long screw and used a wrench on it to tighten it. Doesn't move at all now.
 
1 - 16 of 16 Posts
Top