Polaris RZR Forum - RZR Forums.net banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Can anyone help me out with this? I have a 2020 1000s I don't know what this fuse powers up. I have disconnected every connector that I could find and still have this issue.
 

·
Registered
Joined
·
1,248 Posts
Can anyone help me out with this? I have a 2020 1000s I don't know what this fuse powers up. I have disconnected every connector that I could find and still have this issue.
You're going to have to provide more information. No one can help you without more info.
Upload a picture of the fuse and where it is from . Someone will know what the fuse powers up, if it is factory.

When does the fuse clear? Immediately when turning on the key?
Do you own an electrical multi-meter? Can you check for a short to chassis ground?
 

·
Registered
Joined
·
142 Posts
Can anyone help me out with this? I have a 2020 1000s I don't know what this fuse powers up. I have disconnected every connector that I could find and still have this issue.
I cannot help you because you have not provided specific information. A photo or a description of the location of your "fuse" as well as a detailed explanation of whatever "issue" you're experiencing. Pretend that somebody is asking you what you're asking and then ask yourself if can anybody could understand your problem enough to even begin an attempt to provide an answer?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
Sorry guys I left off the (unsw) as the fuse I was having the problem with. I found the problem in the main harness that runs up the middle of the floor pan next to the fuel tank. This circuit is live all the time it powers the speedometer and the ADL connector with this fuse blown the speedo is dead and the engine will not crank.
rzr fuse box.jpg thumbnail_IMG_6064.jpg
 

·
Registered
Joined
·
1,248 Posts
Sorry guys I left off the (unsw) as the fuse I was having the problem with. I found the problem in the main harness that runs up the middle of the floor pan next to the fuel tank. This circuit is live all the time it powers the speedometer and the ADL connector with this fuse blown the speedo is dead and the engine will not crank.
View attachment 674768 View attachment 674769
Good find. I assume that mean Un-switched 10A
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #8 ·
Yes, did some searching on the internet to find that out . I use a power probe short finder, found the location of the short in two minutes
 
1 - 8 of 8 Posts
Top