Polaris RZR Forum - RZR Forums.net banner

1 - 19 of 19 Posts

·
Registered
Joined
·
480 Posts
Discussion Starter #1
Sway bar is making a clunk when going slow or fast, mainly with articulation. Today, I disconnected the sway bar, noise was gone. Is there a way to tell if its coming from the bushings or the end link? Prior to disconnecting, I made sure all the bolts were tight, so I know it wasn't a loose bolt issue. Also, both bushings were just greased.

Sent from my SM-G973U using Tapatalk
 

·
Registered
Joined
·
365 Posts
The clunking noise is the sway bar moving side to side, you can duplicate it by pushing/pulling on it.
New bushings will cure it.
Several posts about clunking sway bars on here
 

·
Registered
Joined
·
480 Posts
Discussion Starter #3
Yea, I've read through so many posts on sway bars. I can move the bar by hand (left to right), but if I move/shake the rzr by hand it won't clunk, only when riding. I didn't know if the end links would make a noise if they were worn out. Also didnt know what a bad bushing would sound like, clunk or a squeal. Plus, theres a lot of people on here with kore knowledge than me.

Sent from my SM-G973U using Tapatalk
 

·
Registered
Joined
·
631 Posts
Yea, I've read through so many posts on sway bars. I can move the bar by hand (left to right), but if I move/shake the rzr by hand it won't clunk, only when riding. I didn't know if the end links would make a noise if they were worn out. Also didnt know what a bad bushing would sound like, clunk or a squeal. Plus, theres a lot of people on here with kore knowledge than me.

Sent from my SM-G973U using Tapatalk
Put a 2 piece shaft collar on the sway bar on the inside inside of each sway bar mount. Granger has them. I don't see why it wouldn't work. Let us know if it does work.
 

Attachments

·
Registered
Joined
·
480 Posts
Discussion Starter #6
Shock Therapy clamp with Energy suspension bushings,, NO clunking
During all my reading, I saw your setup from another post. I was looking into the it since it fit the bill. I found it to actually be a little cheaper to get a setup from Flex Rock. Comes with the bushing and mount. I am going to guess it'll be a similar result. As long as their bushing is quality. If not, at least I'll have the stronger mount.


Sent from my SM-G973U using Tapatalk
 

·
Premium Member
Joined
·
1,006 Posts
My 15 XP and my friends 17 XPT did what yours is doing. Both times it was the links. Replaced with aftermarket links and problem gone.
 

·
Registered
Joined
·
480 Posts
Discussion Starter #8
My 15 XP and my friends 17 XPT did what yours is doing. Both times it was the links. Replaced with aftermarket links and problem gone.
I'm hoping it's the bushings since they are already ordered. If not, I'll be getting links. Did you get the solid ones, or adjustable ones? I was leaning towards solid.

Sent from my SM-G973U using Tapatalk
 

·
Premium Member
Joined
·
1,006 Posts
My 15 XP and my friends 17 XPT did what yours is doing. Both times it was the links. Replaced with aftermarket links and problem gone.
I'm hoping it's the bushings since they are already ordered. If not, I'll be getting links. Did you get the solid ones, or adjustable ones? I was leaning towards solid.

Sent from my SM-G973U using Tapatalk
I did Zbros adjustable and my friend bought new stock links. Both ways solved our problem
 

Attachments

·
Premium Member
Joined
·
198 Posts
My 15 XP and my friends 17 XPT did what yours is doing. Both times it was the links. Replaced with aftermarket links and problem gone.
I'm hoping it's the bushings since they are already ordered. If not, I'll be getting links. Did you get the solid ones, or adjustable ones? I was leaning towards solid.

Sent from my SM-G973U using Tapatalk
I did Zbros adjustable and my friend bought new stock links. Both ways solved our problem
I did the Flex Rock mounts, the Thunderhawk sway bar gusset kit, the ZBroz adjustable sway bar (And created a quick disconnect to adjust on the fly. I call it my "Manual Dynamix" setup :grin), and Assault links. I seriously love that setup!
 

·
Registered
Joined
·
480 Posts
Discussion Starter #13
I'm hoping it's the bushings since they are already ordered. If not, I'll be getting links. Did you get the solid ones, or adjustable ones? I was leaning towards solid.

Sent from my SM-G973U using Tapatalk
I did Zbros adjustable and my friend bought new stock links. Both ways solved our problem
I did the Flex Rock mounts, the Thunderhawk sway bar gusset kit, the ZBroz adjustable sway bar (And created a quick disconnect to adjust on the fly. I call it my "Manual Dynamix" setup :grin), and Assault links. I seriously love that setup!
I'd definitely like to see a pic of that setup.

Sent from my SM-G973U using Tapatalk
 

·
Premium Member
Joined
·
198 Posts
I did Zbros adjustable and my friend bought new stock links. Both ways solved our problem
I did the Flex Rock mounts, the Thunderhawk sway bar gusset kit, the ZBroz adjustable sway bar (And created a quick disconnect to adjust on the fly. I call it my "Manual Dynamix" setup :grin), and Assault links. I seriously love that setup!
I'd definitely like to see a pic of that setup.

Sent from my SM-G973U using Tapatalk
I keep my machine in St George, UT, and will be heading there tonight for a couple of days of riding. I'll snap a photo while I'm up there.
 

·
Electrical Contractor
Joined
·
555 Posts
Sway bar is making a clunk when going slow or fast, mainly with articulation. Today, I disconnected the sway bar, noise was gone. Is there a way to tell if its coming from the bushings or the end link? Prior to disconnecting, I made sure all the bolts were tight, so I know it wasn't a loose bolt issue. Also, both bushings were just greased.

Sent from my SM-G973U using Tapatalk
Mine is coming from the front. I also have the Shock Therapy front sway bar. I also have movement with there bar. They told me that is normal. I am sending my front shocks for them to look at. I have had this noise since they rebuilt my shocks. I think that it is a combo between the sway bar and the springs rubbing on the crossover rings. We will see how it sounds when I get them back.
 

·
Registered
Joined
·
761 Posts
Mine was the bushings. Front and rear were wore out. New ones and no more clunk.
Which bushings did you put in the front? No mods on that right, just a swap? I could see those moving a bit on mine the other day.

Sent from my SM-G973U using Tapatalk

I used all oem. They are stupid cheap. I think 3 or 4 bucks a piece. If I remember right they are the same part number front and rear. Took me all of 30 mins to do them all.
 

·
Premium Member
Joined
·
198 Posts
I did the Flex Rock mounts, the Thunderhawk sway bar gusset kit, the ZBroz adjustable sway bar (And created a quick disconnect to adjust on the fly. I call it my "Manual Dynamix" setup :grin), and Assault links. I seriously love that setup!
I'd definitely like to see a pic of that setup.

Sent from my SM-G973U using Tapatalk
I keep my machine in St George, UT, and will be heading there tonight for a couple of days of riding. I'll snap a photo while I'm up there.
20190817_074211.jpg

Sorry it took me so long to get this posted. You can see all the stuff I have in there to support that Frame & sway bar. Plus, you can see my homemade quick release for the zbroz sway bar. I love that thing!

Sent from my SM-G935V using RZRForums.net mobile app
 

·
Registered
Joined
·
480 Posts
Discussion Starter #18
Gonna check out that sway bar. So far, the new bushings are quiet. I like the thought of an adjustable sway bar too. Thanks

Sent from my SM-G973U using Tapatalk
 

·
Electrical Contractor
Joined
·
555 Posts
I got my shocks back from Shock Therapy. They had told me that the clunk is from the shocks. They rebuilt them and adjusted the springs. They did say that limit straps will stop the clunking noise. They said that the shock are topping out, which is causing the noise. We will see what happens this go around. I do have their front sway bar kit, but did not change out the bushings. I am going to order a set before the next ride. Also, I think that I want to change out the front link. Any suggestions? They also told me to ditch the Z-Broz racing front A-Arms. I will either go back to stock or get the HCR OEM replacements.
 
1 - 19 of 19 Posts
Top