Polaris RZR Forum - RZR Forums.net banner

1 - 8 of 8 Posts

·
Premium Member
Joined
·
1,405 Posts
Discussion Starter #1
:rm_thumbdown:
Anyone have issues with them?
First off I broke 3 of the 4 clips quickly. They seem thicker than the OEM ones maybe thats why? I pulled my old ones and reused them.
2nd: Sitting on jackstands the boots came off due to the angle. They are glued on...Not sure why they would be glued? Never had an issue with the OEM ones.
3rd: I have 1 balljoint that seems bigger slightly as it will not go in either knuckle the other 3 slide right in any of the holes. I guess it will go on if I beat it with sledge but thats not right.
The bags they came in had been cut open and retaped. Maybe they had an issue and these made it back to the shelf?
I hope its not me but damn....I will never get this LSR kit finished.
Its gonna suck to take the arms off etc... to swap them out.
Anyone have good luck with any other aftermarket ones? Or just go back to the popo ones?

Thanks!!
 

·
Premium Member
Joined
·
1,405 Posts
Discussion Starter #2
Maybe I need beer to make the hole.......
Gonna mess with it tommorrow as I was gettin frustrated...time to walk away.
 

·
King of crash!
Joined
·
31,882 Posts
i had to slightly grind the a rms so the ball joint would go in all the way very minor amount...but the rest was easy as could be...... i took it out and hammered on it all weekend and it held up fine
 

·
Premium Member
Joined
·
1,405 Posts
Discussion Starter #4
Had to grind the LSR arms to get the clips on, prolly due to the powdercoat. I am sure my wife would go out there and it would go right together....How are you keeping your boots on?
 

·
Registered
Joined
·
4,430 Posts
Ugh, I wouldn't grind or alter the arms to get those balljoints to fit. I've got a LSR+4 and my stock stuff went in like butter. I used a very small brass hammer to tap them in. They are suppose to be a snug fit, but nothing near sledge hammer tight. The arms are top quality, I think the joints you got aren't I would grind on them lol. Or even better send them back.
FWIW stock ball joints seem to hold up pretty well. I've replaced one in 1200 miles of mud and water.. That one was a front lower that had a bad bearing and tie rod end. One of the main reasons I got a LSR kit was that it used stock joints. Heims don't work to well around here. I would be worried about the boots not staying on.. Around here muddy water is what kills this stuff. The ball joints on my tierods were Packed with mud. So much so the boot is all that was holding it together lol.
 

·
King of crash!
Joined
·
31,882 Posts
you miss understood what i ment...they fit perfect in the hole it was the thickness that was off part of it was powdercoating... i had to use a dremil to gring the paint and a very small amount offto get the retainer snap ring to fit
 

·
Premium Member
Joined
·
1,405 Posts
Discussion Starter #8
Wonder what they sold me then. They aren't popo's....
 
1 - 8 of 8 Posts
Top