Polaris RZR Forum - RZR Forums.net banner
1 - 5 of 5 Posts

·
Rzr spy
Joined
·
2,489 Posts
Discussion Starter · #1 ·
Hey all, I'm doing a direct stereo swap. I have power coming to my hot and it's grounded properly.

There's 2 hots to choose from on the stereo (switched and permanent). I've tried both and the fuse is good. Stereo won't turn on.

Anything obvious that I'm missing? Btw, stereo was functioning when I bought it.
 

·
Registered
Joined
·
1,102 Posts
Try wiring the switched and permanent together to your hot.
 

·
Registered
Joined
·
1,102 Posts
Try wiring the switched and permanent together to your hot.
Another FYI- wiring the 2 together it will always draw power from the battery. Might be a good idea to put a switch on the switched lead. It just sucks that that your presets will go away every time you turn the switch off. I went with an Ipod setup and like it alot more.
 

·
Premium Member
Joined
·
320 Posts
what they said....

BOTH wires would have to be hooked up to make the headunit work, not just one of them. And the accessory (usually red) should be hooked up to a switch or an ignition switched wire. However, some people hook up both wires to a switched source since the radio is ALWAYS drawing power even with the swich off for memor, clock etc... It's not much but... If you switch both wires you won't have a memory so choose which option is best for you.

Trevor
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top