Polaris RZR Forum - RZR Forums.net banner

1 - 14 of 14 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
So just got my 2020 turbo s velocity and when going high speeds it is all over the place.... I check tire pressure (14psi) in all 4 tires trying to see what else to look for or if that’s normal thanks you
 

·
Aspiring Perfectionist
Joined
·
5,090 Posts
So just got my 2020 turbo s velocity and when going high speeds it is all over the place.... I check tire pressure (14psi) in all 4 tires trying to see what else to look for or if that’s normal thanks you
Brand new machine with no mods? Can you provide a little more description of what you're calling "all over the place'? What is your past experience with driving a sxs or offroad vehicle at higher speeds?
 

·
Premium Member
Joined
·
1,008 Posts
Have you hit anything hard with the front tires? Look and see if your rack is still connected with all four bolts, loose or if there are any cracks.

Steve
 

·
Registered
Joined
·
116 Posts
You may want to check the tow on the tires as maybe the dealer did not set things up correctly. Other then that look for loose parts in the steering and give everything in the front end a really good once over.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
Brand new machine with no mods? Can you provide a little more description of what you're calling "all over the place'? What is your past experience with driving a sxs or offroad vehicle at higher speeds?
Machine gets Squirrley at high speeds no mods yet iv driven my buddy’s 2016 turbo and his is fine no modes other than cage on his
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
Have you hit anything hard with the front tires? Look and see if your rack is still connected with all four bolts, loose or if there are any cracks.

Steve
Ok will double check everything new to the sxs world thing only has maybe 130 miles on it
 

·
Registered
Joined
·
6 Posts
Discussion Starter #7
You may want to check the tow on the tires as maybe the dealer did not set things up correctly. Other then that look for loose parts in the steering and give everything in the front end a really good once over.
It has been like this since iv got it from the dealer
 

·
Registered
Joined
·
116 Posts
My old Honda rancher 350 was all messed up from the dealer they failed to set it up correctly you would be surprised what the person at the dealer can miss doing a setup.

My tires were towed out 1/2 inch per side and one wheel had loose lug nuts.

Make sure the tie rods are tight check the sway bars as well.

How is it all over the place? If you go down a paved road at say 40 what does it do, does it wonder all over the place even thought you are holding the steering wheel straight or is it only acting bad on certain types of conditions.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #10
My old Honda rancher 350 was all messed up from the dealer they failed to set it up correctly you would be surprised what the person at the dealer can miss doing a setup.

My tires were towed out 1/2 inch per side and one wheel had loose lug nuts.

Make sure the tie rods are tight check the sway bars as well.

How is it all over the place? If you go down a paved road at say 40 what does it do, does it wonder all over the place even thought you are holding the steering wheel straight or is it only acting bad on certain types of conditions.
Seems fine on pavement drives straight
 

·
Super Moderator
Joined
·
7,663 Posts
Take a string around it. Front should be toe-out about 1/8 to 1/4, no more. See YouTube for procedure.

Sent from my S9+ using Tapatalk Pro
 

·
Registered
Joined
·
114 Posts
Guessing toe is wrong. When mine had too much toe out it was real squirrell. Set it to 1/8 or less and was way better. Also check your rear swaybar. Mine was broken and side to side sway was terrible.
 
1 - 14 of 14 Posts
Top