Polaris RZR Forum - RZR Forums.net banner

1 - 7 of 7 Posts

·
Registered
Joined
·
155 Posts
Discussion Starter #1 (Edited)
I parked my S for more that 5 months without disconnecting the battery panel or starting it during this period, yesterday I tried to start it;s no charge at all even the display was showing nothing, I charged it using charging wires connected to my car battery S started once I just disconnect the charging wires it engine died tried to restarting it was only cranking till the battery dry out..I got original new battery the S started during my fun time playing around in sand (battery icon flashed on the display) and the display back up light was flashing too...today I tried to start RZR..... not start..I jumped it using the same way yesterday started...just after one hour the was no charge in new battery, do you think that the ISSUE IS WITH DENAMO and the battery is not being recharge please help and advise what I should do now??
 

·
I just wanna ride
Joined
·
3,641 Posts
I would check all the fuses and have your new battery recharged before trying it again.
 

·
Desert Rat
Joined
·
2,118 Posts
If it's not charging, and the battery goes dead, the engine will die. There has to be some voltage to "excite" the stator or the charging system won't charge. I'd start with a fuse check, then it gets more serious. You'll have to look at the charging system.
 

·
The Beast
Joined
·
336 Posts
Check the manual. There's a diagnostic for the battery and alternator. Sounds like you alternator is bad.
 

·
Registered
Joined
·
28 Posts
If it was a new battery make sure you charge it for a day or so. I had the same problem once on a quad got in a hurry to ride on a new battery and it wouldnt take a charge, trickle charged a few days and never had another issue. just my $.02
 

·
King of crash!
Joined
·
31,882 Posts
we dont have a alternator..its a stator... takes a good 12 volts to eciteit and start charging...

also the rzr is draining the battery 24/7dont forget about that.
 

·
Registered
Joined
·
279 Posts
Hopefully you've already considered this but make sure you didn't have gas that's been sittin in there for 5 months. I know it doesn't have anything to do with the battery holding a charge but you wouldn't want that gummin up the engine on ya....
 
1 - 7 of 7 Posts
Top