Polaris RZR Forum - RZR Forums.net banner

1 - 9 of 9 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
So I have a brand new rzr, and I've only put about 100 miles on it so far. My problem is that there are already squeaking noises. They aren't coming from the shocks, but the body. Can anybody tell me why I have noises and how to get rid of them?
 

·
Banned
Joined
·
399 Posts
I greased the lower and upper rear hub bolts and shock bolts no noise now. Will see how long it last.
 

·
Registered
Joined
·
232 Posts
I have about 25 hours on mine and its done it since about 10. Getting in and out and also hitting certain bumps or ground orientations. I figure I will just buy a stereo soon to fix that.
 

·
Registered
Joined
·
140 Posts
I have about 25 hours on mine and its done it since about 10. Getting in and out and also hitting certain bumps or ground orientations. I figure I will just buy a stereo soon to fix that.
Call SSV Works in Augora Hills, CA ask for Trevor Kaplan and he will hook you up with a killer stereo.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #8
I found out what the problem was - The dealership forgot to tighten the bolts connecting the shoulder protector part of the roll cage to the main frame. All I had to do was get a couple of socket wrenches and tighten it down - No more squeaking! BTW, the new 2011 rzr's rock! I went up and down Providence canyon in Northern Utah in about 2 hours!
 

·
Registered
Joined
·
335 Posts
Mine did the same thing, very effen annoying. I pulled the shocks off pulled out the bushings and rubber grommets, (very very dry) greased the hell out of them no more squeaks.
 
1 - 9 of 9 Posts
Top