Polaris RZR Forum - RZR Forums.net banner

1 - 7 of 7 Posts

·
Registered
Joined
·
916 Posts
Discussion Starter #1
I have an 09 LE non-s and I just noticed the spring on the drivers side rear is starting to rub on the shock. I have a little over 600 miles on it. Is this common, do I need new shocks, or just some new makin' trax springs?
 

·
Registered
Joined
·
278 Posts
mine were doing the same thing, no problems out of them, then i put spacers on and the springs almost look like a C shape lol but no problems so far
 

·
Registered
Joined
·
916 Posts
Discussion Starter #5
Thanks for the replies, looks like I need to start saving some coin for the makin' trax springs. Do they make a considerable difference going through the whoops? mine really likes to buck.
 

·
Registered
Joined
·
4,604 Posts
Thanks for the replies, looks like I need to start saving some coin for the makin' trax springs. Do they make a considerable difference going through the whoops? mine really likes to buck.
Way-Good Move....Before I got my MT3s W/Progressive Springs From Steve I did my home-work for over 6 months...because the shocks and Spring are very costly..I for sure wanted to make certain I got Way-Good ones, with great customer service:) ...Thats why it took me so long..I asked A truck load of Members... Hey whats a Way-Good Shocks and Springs??... Over 95% came back and said the same thing..They kinda sounded like a broken record:rofl3:...Call Steve he is the shock and spring guru here on the forum is what most all recommended....Seems to me to get this kind of word of mouth advertising...He certainly must be doing something right and have a Way-Awesome product to have this many Way-Happy Campers:)
__________________
 
1 - 7 of 7 Posts
Top