Polaris RZR Forum - RZR Forums.net banner

1 - 13 of 13 Posts

·
Registered
Joined
·
916 Posts
Discussion Starter #1
My battery was dead a week ago so I charged it and installed a battery tender jr. The battery tender showed that the battery was charged when I unplugged it today and tried to start it. When I turned the key it turned over very slow and almost acted like it wasn't going to start when all of a sudden it fired up. I shut if off and checked the voltage at the battery with a multi-meter it was 13v. When I started it again it did the same thing. Any ideas what might be causing it to crank so slow?
 

·
Registered
Joined
·
15,386 Posts
hmmm,,, maybe the battery is putting out the right voltage, but not enough amperage?
try a different battery or some jumper cables and see if it cranks better... that would tell you if it is time for a new battery.
 

·
Registered
Joined
·
352 Posts
mine did that and it was a bad starter, it also sound like the started turn rough,then all at once it would not turn over at all
 

·
Registered
Joined
·
916 Posts
Discussion Starter #4
I tried charging it again and still the same outcome. I then hooked up jumper cables and it fires right up. I didn't think the battery would go out this soon. I was planning on adding a second battery sometime to run the stereo and gauges, I guess the stereo was too much of a load on the battery. Looks like I will be getting an optima or an odysey sooner than I thought. Any of the vendors have good deals right now?
 

·
Registered
Joined
·
55 Posts
mine did the same thing. I went through 2 stock batterys then I got a GOOD aftermarket one and had no problems since. It's been more than a year and it is still going strong. I start it once a week just to be sure it's ready when im ready to go.
PS... I haven't charged it yet.
 

·
Registered
Joined
·
1,080 Posts
hmmm,,, maybe the battery is putting out the right voltage, but not enough amperage?
try a different battery or some jumper cables and see if it cranks better... that would tell you if it is time for a new battery.
X10
A bad battery will often times show good voltage but have no balls ( Amps) to back it up:ride:
 

·
Registered
Joined
·
916 Posts
Discussion Starter #9
Well after looking around I have decided to go with the Odyssey PC925L since it will fit in the stock location. After reading on the forum it sounds like people are having good luck with this battery. I may eventually add a second 925 into the mix with an isolator but hopefully this will work for me for now. Maybe the vendors can speak up and let me know if anyone has this battery in stock and any deals?
 

·
Registered
Joined
·
1,080 Posts
Well after looking around I have decided to go with the Odyssey PC925L since it will fit in the stock location. After reading on the forum it sounds like people are having good luck with this battery. I may eventually add a second 925 into the mix with an isolator but hopefully this will work for me for now. Maybe the vendors can speak up and let me know if anyone has this battery in stock and any deals?
Here is a link to a company that sells them for $150 and free shipping:ride:
www.rzrforums.net/general-rzr.../34216-pc925l-odyssey-battery-150-a.html
 

·
Registered
Joined
·
916 Posts
Discussion Starter #11
Well after looking around I have decided to go with the Odyssey PC925L since it will fit in the stock location. After reading on the forum it sounds like people are having good luck with this battery. I may eventually add a second 925 into the mix with an isolator but hopefully this will work for me for now. Maybe the vendors can speak up and let me know if anyone has this battery in stock and any deals?
Here is a link to a company that sells them for $150 and free shipping:ride:
www.rzrforums.net/general-rzr.../34216-pc925l-odyssey-battery-150-a.html
Awesome, thanks man.
 

·
Registered
Joined
·
1 Posts
hello NFK. i am running into the same issue, i know this is an older post, but did the odyssey fix the problem or is it something else? i am starting to think a bad starter on mine
 

·
Registered
Joined
·
916 Posts
Discussion Starter #13
Yea. The odyssey problem fixed the problem. I ran that battery until 2018 and it was still going strong at that point.

Sent from my S8+ using Tapatalk
 
1 - 13 of 13 Posts
Top