Polaris RZR Forum - RZR Forums.net banner

1 - 7 of 7 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter #1
Any suggestions on how to run wires from my ride command to an amp and then to tower speakers that I'm mounting to the rear roll cage? Don't want to go under the vehicle, but would like to hide the wires for a clean look. Do I need the factory aux harness from Polaris? I have a 2017 Razor xp 1000 with ride command.
 

Attachments

·
Registered
Joined
·
548 Posts
There are openings in the roll cage itself you can run the wires into, I'd suggest using a small fish tape to get them from the front to the rear.
 

·
Registered
Joined
·
260 Posts
I am not sure about the newer ones, but I have the original MB Quart audio pods and PIDD V2. I am using the Polaris OEM harnesses, and the biggest gripe I have is the connectors. Yes, you can fish the wires themselves inside the stock cage, but you still are going to have this ridiculous mess of large connectors. I haven't done it yet, but I am going to eventually cut all of them out and and just use butt splices so that it doesn't look so stupid.
 

·
Registered
Joined
·
166 Posts
Where do you mount the amp? I ran wire along the front driveshaft tunnel, but I used a loom cuz it gets hot under there. I imagine that would be a good way to get the RCA's from behind the Ride Command head unit to where ever your amp is mounted, then as others have mentioned you can feed actual speakers wires inside the cage tubing.
 

·
Registered
Joined
·
264 Posts
The vacuum technique works great


Sent from my iPhone using Tapatalk
 
1 - 7 of 7 Posts
Top