Polaris RZR Forum - RZR Forums.net banner
1441 - 1460 of 1482 Posts

·
Registered
Joined
·
2,327 Posts
my VR went out also started over charging at 18v, it burnt up the computer. but dealer fixed me up within two hours. they even pulled computer from another rzr to get me going so im happy. good thing for extended warranty!
That is a great dealer!
 

·
Registered
Joined
·
610 Posts
I just heard back from Ride Now. My rzr 1000 has a bad wiring harness also. Should have it back tomorrow. What a PITA to figure out! Hope it runs great now.
 

·
Registered
Joined
·
2 Posts
I just purchased a 2015 rzr xp 4 1000 Friday 3-6-15 I noticed a TERRIBLE noise coming from the front driveline so I called the dealer {Okeefonkee Cycle in Blackshear Ga to inform them of the problem, The sales man said they all make the chattering and bad vibration sound.. Im very disappointed.. I feel for 24,000 plus dollars POLARIS should find the problem and fix it!!! If the problem is not solved this WILL BE MY LAST POLARIS PRODUCT!!!! Its awful that a brand new machine sounds and vibrates so bad that you can't hear your passenger. I looked the front differential over and noticed a lot of play were the cv axles go in the diff.. Not sure if this is the problem.. If any one comes up with a solution please post... Sorry for the complaining Im just disappointed!!~!!
 

·
RVRDADD
Joined
·
6 Posts
I never heard of this problem. I have at least 10 friends that have either the 2014 or 2015 XP 1000 s, none of them including myself have a noise in the front end. the salesman either doesn't know what he's talking about or he's just a con man. take it back and insist that they fix or replace the vehicle.
 

·
Registered
Joined
·
202 Posts
I just purchased a 2015 rzr xp 4 1000 Friday 3-6-15 I noticed a TERRIBLE noise coming from the front driveline so I called the dealer {Okeefonkee Cycle in Blackshear Ga to inform them of the problem, The sales man said they all make the chattering and bad vibration sound.. Im very disappointed.. I feel for 24,000 plus dollars POLARIS should find the problem and fix it!!! If the problem is not solved this WILL BE MY LAST POLARIS PRODUCT!!!! Its awful that a brand new machine sounds and vibrates so bad that you can't hear your passenger. I looked the front differential over and noticed a lot of play were the cv axles go in the diff.. Not sure if this is the problem.. If any one comes up with a solution please post... Sorry for the complaining Im just disappointed!!~!!
Read this thread:http://www.rzrforums.net/rzr-xp-1000/119185-xp-1000-first-run-issues-fixes.html
Apparently this is a common problem. This link was from the very first post of this thread.
Mark
 

·
Registered
Joined
·
20 Posts
I just purchased a 2015 rzr xp 4 1000 Friday 3-6-15 I noticed a TERRIBLE noise coming from the front driveline so I called the dealer {Okeefonkee Cycle in Blackshear Ga to inform them of the problem, The sales man said they all make the chattering and bad vibration sound.. Im very disappointed.. I feel for 24,000 plus dollars POLARIS should find the problem and fix it!!! If the problem is not solved this WILL BE MY LAST POLARIS PRODUCT!!!! Its awful that a brand new machine sounds and vibrates so bad that you can't hear your passenger. I looked the front differential over and noticed a lot of play were the cv axles go in the diff.. Not sure if this is the problem.. If any one comes up with a solution please post... Sorry for the complaining Im just disappointed!!~!![


A friend and I both had a bad vibration and noise coming from the front end of our 1000. Took to dealer with no help. Spent many hours trying to figure it out. Service bulletin z-13-01 fixed both of them. Its a non current bulletin but fixed 2 machines even though the VIN numbers didn't match the ones that needed to be corrected. Its easy enough to try before you pull your hair out like I did:sad:
 

·
Registered
Joined
·
330 Posts
Almost had a crispy Rzr 1000 last night.

Had my oil changed at the dealer back in January and since then I have taken it out very other weekend.

Last night about two minutes after I started rolling, one of my friends told me that I had a fire in the back, I thought he was kidding but still jumped out and turned the Rzr off, and to my surprise he was not kidding at all.

It was not a huge fire but it was probably going to get there, grabbed the handy dandy fire extinguisher (best freaking purchase ever) and fire was out.

Oil was all over the place and when I checked the dipstick it was dry, in two minutes it was drained. I kept looking to see if a hose had busted or something else around the engine had broken but after a few minutes of looking for any problems, I noticed that the seal around the oil filter had popped and it spilled oil to the exhaust manifold.







Took it to the dealer today and service tech said that he had never seen anything like this.

Good thing I'm still under the warranty and they did the oil change, plus I have a 4 year extended warranty. Let's see what they say about coverage and how long it takes to change an oil filter.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
45 Posts
I would guess when the dealer changed the filter the old gasket stay attached and there was two gaskets under the filter.


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
2,224 Posts
Almost had a crispy Rzr 1000 last night.

Had my oil changed at the dealer back in January and since then I have taken it out very other weekend.

Last night about two minutes after I started rolling, one of my friends told me that I had a fire in the back, I thought he was kidding but still jumped out and turned the Rzr off, and to my surprise he was not kidding at all.

It was not a huge fire but it was probably going to get there, grabbed the handy dandy fire extinguisher (best freaking purchase ever) and fire was out.

Oil was all over the place and when I checked the dipstick it was dry, in two minutes it was drained. I kept looking to see if a hose had busted or something else around the engine had broken but after a few minutes of looking for any problems, I noticed that the seal around the oil filter had popped and it spilled oil to the exhaust manifold.







Took it to the dealer today and service tech said that he had never seen anything like this.

Good thing I'm still under the warranty and they did the oil change, plus I have a 4 year extended warranty. Let's see what they say about coverage and how long it takes to change an oil filter.


Sent from my iPhone using Tapatalk

I guess that just goes to show that even highly skilled polaris trained technicians can make rookie mistakes.

Glad you got the fire put out quickly!
 

·
Registered
Joined
·
148 Posts
If the filter is actually tight then the oil pressure relief valve stuck and high oil pressure blew the seal out just like the old 700s and 800 twins wouod do.
 

·
Registered
Joined
·
330 Posts
Almost had a crispy Rzr 1000 last night.

Had my oil changed at the dealer back in January and since then I have taken it out very other weekend.

Last night about two minutes after I started rolling, one of my friends told me that I had a fire in the back, I thought he was kidding but still jumped out and turned the Rzr off, and to my surprise he was not kidding at all.

It was not a huge fire but it was probably going to get there, grabbed the handy dandy fire extinguisher (best freaking purchase ever) and fire was out.

Oil was all over the place and when I checked the dipstick it was dry, in two minutes it was drained. I kept looking to see if a hose had busted or something else around the engine had broken but after a few minutes of looking for any problems, I noticed that the seal around the oil filter had popped and it spilled oil to the exhaust manifold.







Took it to the dealer today and service tech said that he had never seen anything like this.

Good thing I'm still under the warranty and they did the oil change, plus I have a 4 year extended warranty. Let's see what they say about coverage and how long it takes to change an oil filter.


Sent from my iPhone using Tapatalk

Picked up my Rzr today after being there for the above problem. It was check twice for the pressure relief valve and compared with two brand new units that were in the shop and my vehicle was is in par with the new ones, the same pressure and specs.

The dealer did a great job at cleaning it up and making it look like new again, washed nice and purdy!!!!

Thank good nothing got fried and no major work was done besides a brand new oil and oil filter All covered by warranty so all good to go. I was told that I could have been a faulty oil filter (who knows). We will see what happens next, at least it's documented.

Once back home, took it out for a 20 mile spin and it's running like new.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
8 Posts
Hello out there. Just got back from Windrock and ride royal blue. First outing in my 2014 rxr 1000 xp. Very happy with ride. Before I left I measured clearance under the front and rear Diff and it was 13 inches (front and back) It now measures 11-1/2 Does anyone make a bolt on 2" lift kit to get it back to factory height? Had Jeeps for 50 years , had a Can Am commander for 1 year. This thing is awesome .. For a out of the box ride it is unbelievable ...Bluebayou1
 

·
Registered
Joined
·
2,327 Posts
Hello out there. Just got back from Windrock and ride royal blue. First outing in my 2014 rxr 1000 xp. Very happy with ride. Before I left I measured clearance under the front and rear Diff and it was 13 inches (front and back) It now measures 11-1/2 Does anyone make a bolt on 2" lift kit to get it back to factory height? Had Jeeps for 50 years , had a Can Am commander for 1 year. This thing is awesome .. For a out of the box ride it is unbelievable ...Bluebayou1
Hard to believe the springs collapsed 1-1/2" after one ride. To answer your question, Racer Tech sells a 2" lift kit. keep in mind this will change your shock mounting angles and stiffen your ride.

When you took that 1st measurement, had you previously jack up the vehicle and not driven it around to let the suspension settle?

My suggestion, would be to jack up the car (wheels off ground), adjust the shock preload collars, take it for a ride and re-measure. Repeat until ride height is achieved. Collars shouldn't have to move more than around 1/2" or so. Also, before you move those collars, make sure the threads are super clean to avoid any galling.
 

·
Registered
Joined
·
8 Posts
Thanks for the reply..OK here is page 2.. Put on Assault rear radius rods, Assault tie rod steering, Winch, front and rear bumperette, spare tire rack and spare tie, large cooler box, 4 point harness, windshield, roof, sliders, door panels, extra tools, 4 new Rhino axles...All while it was up and down on the lift...... Oh My!!!! I then measured it before I loaded it on the trailer. How soon we forget.... I used to have a grand national turbo motor in my Jeep rock crawler...It was good ... This thing is quicker... bluebayou1
 
1441 - 1460 of 1482 Posts
Top