Polaris RZR Forum - RZR Forums.net banner

1 - 6 of 6 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Has anyone had the same problem?
I have a 2019 rzr xp 4 1000 and I have been getting this code, after a while the rzr won´t accelerate at low rpm´s and then sometimes just stops and turns off, after turning it on again i have to give it more gas so the rpm´s are higher and continue but with the same issue and the engine light on the dashboard turned on, if I stop for about half an hour then something cools off and can continue.
Anyone knows or have had this problem?
Thanks in advance.
 

·
Registered
2014 XP4 1000, tons of mods
Joined
·
414 Posts
 

·
Premium Member
Joined
·
2,545 Posts
Has anyone had the same problem?
I have a 2019 rzr xp 4 1000 and I have been getting this code, after a while the rzr won´t accelerate at low rpm´s and then sometimes just stops and turns off, after turning it on again i have to give it more gas so the rpm´s are higher and continue but with the same issue and the engine light on the dashboard turned on, if I stop for about half an hour then something cools off and can continue.
Anyone knows or have had this problem?
Thanks in advance.

I would check or replace your fuel pump P1170 is Lean condition not rich
520344 15 Adaptive Fuel Correction Valid but above normal -
Too Rich P0170 17 Valid but below normal -
Too Lean P1170
What you are describing is classic fuel pump failure
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
Ok, than you all vey much for your help, i will replace the fuel pump and hopefully get rid of that failure.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #6
I think i solved the problem just by changing the filter that goes on the bottom of the fuel pump assembly, I took the rzr for a drive for more than an hour and had no problem, was able to go 70mph @8500rpm's and probably could of gonne a little faster but runned out of space.

Here are the pics of the old and new filters.

660340
 
1 - 6 of 6 Posts
Top