Polaris RZR Forum - RZR Forums.net banner

1 - 6 of 6 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter #1
So using the clutch removal bolt i just got in the mail, I was able to pull off the main clutch portion however the flat plate on the engine side still remained. Maybe thats normal but i was expecting it to slide off with the main clutch portion.
Not sure how to get that plate off now. Do i need to unscrew the removal bolt....actually its proving difficult as it went on so hard in the first place.
Never really heard the pop sound i was expecting either if that matters.

Sent from my DROID BIONIC using Tapatalk 2
 

Attachments

·
Banned
Joined
·
904 Posts
Mine came off in one piece. Also, my clutch tool was not long enough so we had to stick an additional piece of metal in there to get it off. Maybe thats the issue?
 

·
Registered
Joined
·
45 Posts
Discussion Starter #5
The removal tool should not screw in hard. It sounds like you may have it cross threaded. I hope this is not the case!
I hand threaded the removal tool bolt in for the majority of the tread depth until it bottomed out. Then put a wrench on it to turn it 1/4 or 1/2 turn while waiting to hear the "pop" sound I'd read about.

Didn't hear that and fearing to crank it any tighter, I reached for the clutch to see if it was loose or ready to slide off and it just did. I think it may have rotated coming off too if that means anything.

Perhaps I unscrewed it from the shaft instead of letting it pull straight off?
Now just the bearing and the inside plate are on the shaft still.
 
1 - 6 of 6 Posts
Top