Polaris RZR Forum - RZR Forums.net banner

1 - 6 of 6 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter #1
2008 rzr, been overheating and shutting down. no leakage out of weeping hole from water pump, if I let it run for 5 to 10 minutes, both water hoses are hot from radiator and in engine compartment, and letting it run for several minutes with radiator cap off the antifreeze starts to over flow, air bleed screw really shows no air, just steady stream, thinking thermostat,or water pump, Polaris wants crazy money for thermostat, so would like to get a few opinions or thoughts on this issue, and a cross reference for a thermostat, fan also doesn't come on unless I disconnect sensor, thanks
 

·
Registered
Joined
·
4,353 Posts
The 800 is very hard to bleed all the air out. Raise the font end with floor jack and try bleeding again. Fill everything, with front raised let run till fan comes on. See what the temp is. Should be in 180 to 190. Let cool totally down and fill again. Keep up till it takes no more.
 
  • Like
Reactions: RZR_Scott

·
Registered
Joined
·
391 Posts
on my 2014 800 the fan doesn't come on until about 205.

Does it get hot when you let the fan run all the time? Well you get where I'm going with that...You say it never comes on when connected correctly???? Well obviously it should.

On that year car I would suspect the radiator too. If it has any signs of white crust or goop inside I think I would just get a new one along with a t-stat.

Doesn't look like a t-stat will be a problem to find


https://www.amazon.com/7052352-7052308-Thermostat-Replace-Sportsman/dp/B07TRLZM62/ref=asc_df_B07TRLZM62/?tag=hyprod-20&linkCode=df0&hvadid=375197107828&hvpos=1o1&hvnetw=g&hvrand=15861590980580259893&hvpone=&hvptwo=&hvqmt=&hvdev=c&hvdvcmdl=&hvlocint=&hvlocphy=9031714&hvtargid=pla-805815826036&psc=1&tag=&ref=&adgrpid=75513194583&hvpone=&hvptwo=&hvadid=375197107828&hvpos=1o1&hvnetw=g&hvrand=15861590980580259893&hvqmt=&hvdev=c&hvdvcmdl=&hvlocint=&hvlocphy=9031714&hvtargid=pla-805815826036
 

·
Registered
Joined
·
4,353 Posts
Should have said wait for the fan to come on then off. When off check temps.
 

·
Premium Member
Joined
·
1,381 Posts
Both hoses get hot, water is circulating.

If thermostat does not open completely, there may not be enough circulation to cool engine.

May not be enough air movement to cool engine.
Are the radiator fins clear of mud, weeds, debris?
Put a light behind radiator (at night), can you see light thru radiator from the front?
 
  • Like
Reactions: RZR_Scott

·
Registered
Joined
·
391 Posts
Sometimes some of the tubes in the radiator get plugged, then the water can circulate too fast thru too little tubes not letting the radiator cool it. I've seen this on cars quite a few times. It's maddening because you can tell it's circulating but still getting hot.
 
1 - 6 of 6 Posts
Top