Polaris RZR Forum - RZR Forums.net banner

1 - 12 of 12 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter #1
I just bought a 2010 RZR-S, with 9 hrs. It has no low gear, and clunks and bangs when in reverse and high gear, almost seems like some teeth are missing inside. Took it to 2nd largest RZR dealer in Canada, the owner said he knew what was wrong before I unloaded off the truck. A $2200 fix, they keep parts in stock. Have not heard yet if they got it fixed.

Keep aware, this is a common problem, and no warranty recalls. Watch out for it.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #3
It better be under warranty, less than 6 months old. I haven't heard anything back yet, told them it was not a panic issue, just fix it in next 2 weeks if possible. They said they have done a few with same problem.
 

·
Registered
Joined
·
1,864 Posts
OK, he said $2200 to fix... but it sounds like it should be under warranty.
Not exactly, he said the dealer said it was a 2200.00 fix, not that they had decided to charge him that as of his drop off as i understand him.He stated it only had 9 hours and was under 6months old. There should be no question about it being under warranty and if mine it had better be or the :shtf1: big time :rofl3: With all these posts about failure, it sounds like a recall or somebody talking to the government about this should be in the works.
 

·
Registered
Joined
·
284 Posts
I can't believe that there has not been a recall or any kind recognition of the problem.
 

·
Registered
Joined
·
1,864 Posts
I can't believe that there has not been a recall or any kind recognition of the problem.
One thing Forums are good for is a place to give people with problems a place to share or vent a problem, a issue can become big news here but in the larger picture it really represents a very small percentage of the units in operation. Ive ridden with hundreds of rzr's over the last two years and only heard of two that have had a issue like this, one was a 09 and the other a 10. Not to minimize the frustration of those people with the problem at all, just to say IMO this is why polaris doesnt jump up and do a recall. Hopefully polaris will step up and start fixing the issues for people like they did on the 08 dust issues. No recall was offered then either.
 

·
Registered
Joined
·
3 Posts
I had the same problem with mine. the issue is that the low range gear is an internal gear that is "soldered" into an external gear. to me it looks like it was intended to be intentional weak link to avoid breaking more expensive components. the replacment gear is not exactly inexpensive (200.00). I replaced the gear in mine and have had no further issues. high range is engaged with four huge lugs and low range is just a quarter inch wide set of teeth. this seems a bit backwards to me? If anyone else has any trans issues send it to me and i would be glad to fix it for you. I am ASE certified master technition. with 15 years mechanical experience with everything from crotch rockets to Lingenfelter corvettes. pm me if interested. I could save you a ton of cash!
 

·
Registered
Joined
·
839 Posts
I had the same problem with mine. the issue is that the low range gear is an internal gear that is "soldered" into an external gear. to me it looks like it was intended to be intentional weak link to avoid breaking more expensive components. the replacment gear is not exactly inexpensive (200.00). I replaced the gear in mine and have had no further issues. high range is engaged with four huge lugs and low range is just a quarter inch wide set of teeth. this seems a bit backwards to me? If anyone else has any trans issues send it to me and i would be glad to fix it for you. I am ASE certified master technition. with 15 years mechanical experience with everything from crotch rockets to Lingenfelter corvettes. pm me if interested. I could save you a ton of cash!
My wuarrantee expires today I will send it to you if I have a problem, takes a little of the worry out of the way of not having wuarrantee. Thanks Kevin
 

·
Registered
Joined
·
34 Posts
Discussion Starter #11
Haven't heard back from the dealer, so will call in this week to see if they got it fixed, been there 3 weeks, so hopefully they found time. They are central Alberta's largest SxS dealer, and the owner told me they keep parts in stock.

What was the original issue on the 2008 RZR air cleaner problems? I have a 2008 that refuses to rev up above 3500 rpm. I just replaced the fuel pump, old one 20 lbs pressure, new one pumps out 39 psi, but, new fuel pump has not changed the crappy engine running, never improved anything. Not getting very impressed with these issues.

Anyone wanna buy a used 2008 RZR?
 

·
Just kidding!
Joined
·
10,754 Posts
Haven't heard back from the dealer, so will call in this week to see if they got it fixed, been there 3 weeks, so hopefully they found time. They are central Alberta's largest SxS dealer, and the owner told me they keep parts in stock.

What was the original issue on the 2008 RZR air cleaner problems? I have a 2008 that refuses to rev up above 3500 rpm. I just replaced the fuel pump, old one 20 lbs pressure, new one pumps out 39 psi, but, new fuel pump has not changed the crappy engine running, never improved anything. Not getting very impressed with these issues.

Anyone wanna buy a used 2008 RZR?
I do but your too far away.This doesnt supprize me popo wont step up to the plate.They screwed alot of people with the air cleaner issue.It sounds like there at it again.
 
1 - 12 of 12 Posts
Top