Polaris RZR Forum - RZR Forums.net banner

41 - 44 of 44 Posts

·
Registered
Joined
·
12 Posts
Pegdragger,

any updates on your situation? i am going through the same ordeal at the moment and as well razorpilot offered advise which I'm running with at the moment but curious to your outcome while i get a response back from my dealer
 

·
Registered
Joined
·
1,259 Posts
RAZORPILOT-thank you, I appreciate it. Its sad when a comlete stranger seems to to help more than the manufacturer. I'll reach out Tuesday after the Holiday
That's what this forum is about too, getting real help with isuues !!!!!!!!!!!!!!!
 

·
Registered
Joined
·
2 Posts
Hi all! My name is Sergey and I am from Russia. I have a similar problem with the motor. after 100 miles the motor jammed. after opening of the motor saw that shot off the bottom of piston and the lower oil ring. when the motor is jammed in the motor oil was not. never leaked oil!

dealer told me that these problems with the engine in the world was not, but after reading your forum I saw the opposite.

Failed to get a response to your dealer about the reason for this failure?






 

·
Registered
Joined
·
626 Posts
Hi all! My name is Sergey and I am from Russia. I have a similar problem with the motor. after 100 miles the motor jammed. after opening of the motor saw that shot off the bottom of piston and the lower oil ring. when the motor is jammed in the motor oil was not. never leaked oil!

dealer told me that these problems with the engine in the world was not, but after reading your forum I saw the opposite.

Failed to get a response to your dealer about the reason for this failure?






Yes..looks like you had the same problem as a lot of us..lower piston land gave way...then you consumed oil at a high rate, till the motor gave up.
I was using over 1qt every 50 miles..
Hope Polaris takes care of you..
 
41 - 44 of 44 Posts
Top