Polaris RZR Forum - RZR Forums.net banner

1 - 9 of 9 Posts

·
Registered
Joined
·
284 Posts
I don't know what you have, I have an 08 and I'm having surging issues. I've replaced plugs and the airfilter.Still happens. I know I have a charging issue. At night my lights go dim and then bright. I've replaced my regulator due the the strange volting issues I'm having.
 

·
Registered
Joined
·
1,860 Posts
Is the surging RPM or speed? As for the lights dimming that will happen when the cooling fan kicks on. May not be your problem just something to think about.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #4
It feels more like an RPM surge.... kinda like it slips and grabs or someting? I dont notice a definate RPM jump tho. almost like a bent wheel type of feeling
 

·
Registered
Joined
·
1,860 Posts
Well you might have a clutch/belt issue. Pull the clutch cover off. Clean everything up. Blow the dirt and grime from both clutches. Look at the belt to see if it's glazed. Makes sure the belt has worn evenly. Check the clutch sheves to see if they are smooth. Then check the clutch weights to see if the are moving freely. Set the display so you can observe both RPM's and speed. Find out exactly what RPM's and what speed the problems happens. If possible try and do it in low gear and see if there is any change. It needs determined if it's and engine problem or clutch problem.
 

·
Registered
Joined
·
1,860 Posts
There is a gasket between the front and back half of the enclosure. There is a foam gasket that fits in a groove between the two halfs. It is intended to be dry. If you power wash you motor you can get water in the vent under the bed. If there is a leak between the two halfs or between the motor and the inner housing, you can get water in there. Unless you spend a lot of time underwater or are over agressive cleaning your motor this is not an issue. I have split my clutch cover numerious times with no issue.
 

·
Registered
Joined
·
284 Posts
My surge went away last night.... I located a loose ground to my battery. So far, no more surging
 

·
Registered
Joined
·
13 Posts
Discussion Starter #9
I think i may have figured out my surging issue. I noticed that I have a bad cv joint on the RR. Im hoping this will fix the issue. Im thinking it may be more of a vibration than a "surge". Im hoping! Fingers crossed.
 
1 - 9 of 9 Posts
Top