Polaris RZR Forum - RZR Forums.net banner
1 - 3 of 3 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
I changed my oil about 2 months ago and since then put on about 700 kilometers. I did not check my oil level in the last 2 months because I have never had a reason to do so (the level is near the same when I change the oil as when I filled it orginally). I happened to check my oil last night and it wasn't even registering on the dipstick..... I decided to add oil until I was in the safe zone and it took about 1 litre which means I could have been running with only 3 litres in the engine during my last trip...Not the end of the world but I am concerned on where the oil went??? Anyone have this problem?? Are these things known to burn oil?? It is a 2011 RZR-S 800 and I have approximately 5000 kilometers on it and up until now I haven't had an issue with the oil level dropping...

Any thoughts?
 

·
Registered
Joined
·
83 Posts
hate to say it but rings are prolly gone, the stock air filter system on these things are extremely in-efficent and have to be checked after every ride and filters have to be changed way more than they should. The piston rings on these machines are extremely sensitive to dust ingestion, it doesn't take that muich dust to have you needing to do a top end job, which is prolly what your gonna need IMO. It's prolly burning the oil by getting by the rings but the synthetic oil doesn't really smoke like regular oil. My 2011 did this it would use 1-1.5qts every 150-200ish miles, honestly I didn't check the air filter as much as I needed to I guess or the oil level due to never having a problem with any other atv that I had ever owned. But if you own a RZR it's runs by it's own set of rules, trust me you MUST chek air filter and engine oil before every ride!!!!! Sorry for your trouble man, hope it works out for the best, do a compression and leakdown test and go from there!
 
1 - 3 of 3 Posts
Top