Polaris RZR Forum - RZR Forums.net banner
1 - 20 of 25 Posts

·
Registered
Joined
·
513 Posts
Discussion Starter · #1 · (Edited)
Issue at full throttle only, running lean on a K&T turbo?

Anyone own or know of a good shop that has installed turbos and can work on the XP with the K&T. I'm from BC so closer to the Vancouver border the better. Need some work done, having issues.


Kevin


Sent from my rzr using Tapatalk
 

·
Registered
Joined
·
513 Posts
Discussion Starter · #3 ·
Yes but I'm not the guy that works on his own machine. So I need a guy to install the stuff or replace it with the working stuff.


Sent from my rzr using Tapatalk
 

·
Registered
Joined
·
1,382 Posts
10/4! There should be some capable tyrbo guys in canada I would talk to some of your high end snowmobile shops those guys are always playing with boost
 

·
Registered
Joined
·
513 Posts
Discussion Starter · #5 ·
The issue is as stands. When under full throttle there is no fuel getting to the engine. I have full boost at all times but once it gets to top end the boost is still at 10psi but I get no fuel. The afr reads 16 plus. Too high. The revs are 78-7900 area. We checked the fuel pressure its ok. We blew into then controller feed back lines and they hold pressure. The injectors get power. So it seems like the fuel controller is in need of replacement. That's the best guess.


Sent from my rzr using Tapatalk
 

·
Registered
Joined
·
513 Posts
Discussion Starter · #6 ·
The thing I found dealing in canada is high prices and lack of knowledge. At most Polaris dealers they rarely deal with XP and even less with turbos. I'm
So scared at how stupid the dealers sound. So I go where the common use is. That's Oregon or Idaho closer to the dunes. But prices in Canada are just too high.


Sent from my rzr using Tapatalk
 

·
Registered
Joined
·
5,422 Posts
my neighbor is having issues with his xp4 k&t turbo fueling as well. he has gone through 2 fuel boxes and still having lean issues. k&t thinks maybe an injector issue?
 

·
Registered
Joined
·
958 Posts
i have the same problem thinking of a power camander v and auto tune and map
ditching the aux injectors and just running 2 big mains
 

·
Registered
Joined
·
513 Posts
Discussion Starter · #10 ·
Ok I'm glad this forum has helped me more that once. I will see about injectors. What type are they? Is it just a auto part you can get anywhere?

Kevin
 

·
Registered
Joined
·
188 Posts
There is a red wire on the fuel controller make sure it is hooked to the positive side of the battery. If it isn't your aux injectors won't turn on. Also make sure your boost signal line isnt pinched off. Just a couple things to double check.
 

·
Registered
Joined
·
513 Posts
Discussion Starter · #12 ·
It might be as simple as that too. I am going to get it looked at in Oregon the next visit. The issue seems to have been happening over a long time perhaps cause I blew out a piston due to detonation and it was a forged piston. In the process of getting a new one the lines could have been pinched or the power line altered. I thought that power would effect the whole thing not just the high end area. Why should the power or negative ground not effect the mid and low or the lights from coming on, meaning the fuel controller.

The issue is complicated by the fact that other people have replaced the box on their xp and still had lean issues.

It is so far the most frustrating thing that has happened to my turbo. Up till now it has been trouble free. I did break a few stock axles but more due to poor airtime jumps and landings. It is related in some sense since the speed and power I gained did make it much worse. Lol.

Kevin
 

·
Registered
Joined
·
188 Posts
The red wire actually supplies power to the aux injectors so they can function. The power to the fuel controller is supplied by the factory injector plugs. Being your kit is a year old or so it could be that your boost signal line has dry rotted and needs to be replaced with a higher quality silicone tubing. I wouldn't think that your injectors would be bad after only a year.
 

·
Registered
Joined
·
513 Posts
Discussion Starter · #15 ·
The red wire actually supplies power to the aux injectors so they can function. The power to the fuel controller is supplied by the factory injector plugs. Being your kit is a year old or so it could be that your boost signal line has dry rotted and needs to be replaced with a higher quality silicone tubing. I wouldn't think that your injectors would be bad after only a year.
Ok. Thanks for the help. I'll just bring it to the shop and have them look at it. I hope it's a simple fix. The line of problems this past summer has been trying at best.


Kevin
 

·
Registered
Joined
·
513 Posts
Discussion Starter · #17 ·
I know it is a little further south but I know quite a few pepes for Canada take there rzr's to RedLine racing in Sweethome Oregon
Good luck
That's my normal shop. I had Cameron put in the kit for me. I was just seeing if anyone closer could do it if I was not heading that south. But I do like Cameron's work and go there for most everything. He put back my rzr after the roll over.

Kevin
 

·
Registered
Joined
·
1,341 Posts
I know it is a little further south but I know quite a few pepes for Canada take there rzr's to RedLine racing in Sweethome Oregon
Good luck
That's my normal shop. I had Cameron put in the kit for me. I was just seeing if anyone closer could do it if I was not heading that south. But I do like Cameron's work and go there for most everything. He put back my rzr after the roll over.

Kevin
Well then you know he is a jerk also :rofl3:
 

·
Registered
Joined
·
513 Posts
Discussion Starter · #19 ·
Lol. I give him a hard time like crazy. And pester him with questions all the time. He didn't like the text charges to Canada so I got him on whatsapp. Lol. I think we have met before or know a few mutual friends.

Kevin
 

·
Registered
Joined
·
1,341 Posts
Lol. I give him a hard time like crazy. And pester him with questions all the time. He didn't like the text charges to Canada so I got him on whatsapp. Lol. I think we have met before or know a few mutual friends.

Kevin
LOL ya I heard about that, we are heading up your way this weekend, hope we can all stay on two wheels Cam has a prob with that :rofl3:
Whilster here we come :ride:
 
1 - 20 of 25 Posts
Top