Polaris RZR Forum - RZR Forums.net banner

1 - 11 of 11 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
Some time back HawkEng had a post on how to wire in or add LED brake lights by using a relay it was post #20 1-29-10 I have a 2010 RZR-4 and have looked at the schematic and wired it just about every way I can think of and it still will not work, from RZR brown to ground to light, from RZR orange to #86 , from RZR R/Y to #30 and 85 , from light orange to # 87A , from light R/Y to #87, I changed out the brown and R/Y slots on the light, is there someone out there that might tell me what I'm still missing , I keep blowing fuses when I step on the brake .
 

·
Registered
Joined
·
1,923 Posts
Go back to stock and start over.
I wired mine from that schematic and it works fine.
If you have changed the wires at the tail lights you must use an LED or you will blow a fuse
using a regular 3157 bulb.
 

·
Registered
Joined
·
681 Posts
You have to wire the relay just like that post showed, but you also have to swap wire position at the bulb connector.....I did it on mine, but I dont remember what went where....Im kinda an expert at automotive electrical so I just did it and was done with it....maybe someone on here know what wire goes where. I can go look at mine tomorrow and post back
 

·
Registered
Joined
·
32 Posts
Discussion Starter #4
All I'm trying to do is add some flashing LED's to what I have using the same bulbs in the tail lights , could that be why I'm having problems?
 

·
Registered
Joined
·
1,923 Posts
YES BIG TIME YES ALL TAIL LIGHTS NEED TO BE LED.
Reread my above post that is your basic problem mixing apples and oranges.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #6
Ok today replaced regular bulbs with LEDs and still will blow fuse, turn on key no tail lights , step on brake and then it blows the fuse. is there any way the RZR-4 is :rollfinger:different from the standard RZR are any of the ones that have responded that have made this change the RZR-4. Something is amuck or I'm just not seeing how it is wired from the drawing or missing a step somewhere.
 

·
Registered
Joined
·
681 Posts
you have to switch the wire position at the tail light bulb so that the ground wire is the shared terminal at the bulb.
 

·
Registered
Joined
·
1,923 Posts
I used this schematic and as stated above switched the wires for the brake light power and ground at each tail lamp assembly.
http://www.rzrforums.net/lighting-stereo-electrical/23531-tail-light-wiring-schematic-3.html
See Bobholthaus post #44.
Mine work fine and also added a high level Tail/Brake lamp too.
Disregard the relay for the trailer portion unless you want that, I did not.
I mounted my relay after the factory connection under the bed so if you take the bed off
it will be part of what comes off.
I hope this helps.:)
 

·
Registered
Joined
·
32 Posts
Discussion Starter #10
All I switched the two wires at the light, wired in the relay per the drawing, used LED tail lights and still would blow out the fuse, gave up and put back to stock. has anyone with an RZR-4 tried this and made it work
 

·
Registered
Joined
·
1,923 Posts
So are you still blowing a fuse after going back to the original wiring setup?
 
1 - 11 of 11 Posts
Top