Polaris RZR Forum - RZR Forums.net banner

1 - 6 of 6 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1 (Edited)
I've got a 2016 1000S that has only 97 hours on it. It's not even due for its first scheduled maintenance yet for crying out loud.
I took it out last weekend with the kids and spent most the day in park just watching them ride around. For what little time I did spend riding I never noticed any issues.
I loaded it up when we were done, unloaded it when I got home...again, never noticed anything wrong.
I haven't touched it since last weekend. I go out today and notice an oil stain on the ground under the rear diff. After looking around I notice that the left rear cv boot is mangled and the entire skid plate under the diff is full of oil.
I unfortunately cannot tell where the leak is originating from, but I don't think it's the cv boot because I ran my hand all the way around it and it's dry.
I also checked the axles to see if they had any excessive play, and rolled the machine back and forth to see if the axles were bent or broke and again couldn't find anything wrong.
I purchased a 5 year 100% warranty with it so I'm not worried about getting it fixed. I'm taking it to the dealer when they open on Tuesday so they can get it fixed up. I'll update when they determine what the problem/cause was.
Just wanted to post this to see if any others have had similar issues.
I'm not naive enough to think that parts on the machine will never break, I just didn't think they would start breaking this soon.:cry:
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
So I finally found out what the leak was...
I initially thought it was the rear diff, due to the location of the leak.
Turns out it was the transmission. The center seal was bad and the transmission was basically split in half.
The service guy said this is the 3rd or 4th 1KS that he's had to fix this problem on already.
Just wanted to give everyone a heads up as apparently I'm not the only one that's having this issue.
 

·
Registered
Joined
·
12 Posts
I am picking up my 1000 S this Wednesday. Thank you or the heads up. Curious as to what you paid for your 5 year 100% warranty. Is that through Polaris or ?

Thanks!
 

·
Registered
Joined
·
15 Posts
Discussion Starter #5
It's a 3 year warranty, not a 5, my mistake. It is a 100%, no deductible for that whole time though.
It's through a company called Century.
I wanna say it was around $750 or so.
The 5 year (which is what I thought I was going to get, but Century stopped offering that about a week before I bought mine) was around $950.
 

·
Registered
Joined
·
41,101 Posts
FYI: The CV Boots have grease in them not a fluid... So if they would have been the culprit it would have been grease slung every where...
 
1 - 6 of 6 Posts
Top