Polaris RZR Forum - RZR Forums.net banner
21 - 40 of 43 Posts

·
Registered
Joined
·
625 Posts
What was the order number?
Order #16739
Sent everything to sales email as requested. Best to review the emails to get all info.

Sales rep was not sure what to do when we spoke on the phone. Said he would work the issue if I sent him everything. I included the shipment form for the order as well.

Pro UTV Parts
ORDER #16739​
Your order is on the way
Your order is on the way. Track your shipment to see the delivery status.
View your order​

UPS tracking number: 1Z23T6T60393419055
Items in this shipment
RS1 A ARMS by L&W Fab - Lower / Red × 1
If you have any questions, reply to this email or contact us at [email protected]
 

·
Registered
Joined
·
625 Posts
What exactly is the problem with these? I need to put a description in the order notes.
I'm sending you the same thing I sent sales guys in email as requested.

Order #16739
Per conversation today I'm sending pics of manufacturing defect of lower A Arm on 2020 RS1. Arm brace is welded about 1/4 inch off compared to right side. Left arm is hitting sway bar bolt and damaging the arm and sway bar bolt.

More pics of measurement will follow. See attached pics to get an idea of the issue.

Note: See first 2 pics where sway bar is gouging the A-arm due to cross brace being welded in wrong location.

Next email same day:

Here are pics of measurement for right and left A arms showing cross brace in different locations causing the interference fit. To me it's about 1/4 inch off.

Tire Bicycle tire Automotive tire Wheel Bicycle frame Automotive tire Automotive lighting Bumper Tire Bicycle part
 

·
Registered
Joined
·
625 Posts
What exactly is the problem with these? I need to put a description in the order notes.
It might help to know these pics were taken with RS1 on lift. Suspension is at full droop so you don't see contact, but do see the damage to the arm as the suspension cycles. This is a well maintained rig as you can see in this pic taken same day we sent emails and pics to sales.

Interior design Wood Flooring Beam Building
 

·
Registered
Joined
·
625 Posts
Got to ask. Why can't you see the original emails with all this info I sent on 24 Sept? Curious about it, not mad.
 

·
craigstumph
Joined
·
13,601 Posts
Discussion Starter · #27 ·
I don't see all the emails that come through. I looked at the order from September 9 2020 and there are not any notes on the order page discussing any problems. I don't see any damage in the photos of the lower a-arms. Shop looks nice.
 

·
Registered
Joined
·
625 Posts
I don't see all the emails that come through. I looked at the order from September 9 2020 and there are not any notes on the order page discussing any problems. I don't see any damage in the photos of the lower a-arms. Shop looks nice.
I can understand that email stuff when you see hundreds a day. I took care of 500 troops and their paperwork near the end of my 22 year career. I hated to open email everyday. Often turned into 12-14hr day and then weekends and holidays were the only days to catch up. Sure made it hard to ride or make one race a month. Glad it's over, but would do it all again for FREEDOM.

Now with a Dream Shop its finally time to enjoy some toys. Life long racer and mechanic with time to enjoy the shop and adventures. Military might have helped make me OCD. Good and bad I guess.

I don't mind posting everything again from page one post 19. Do some larger pics as well.

The notch worn into the A-Arm is easy to see. There is bare metal showing. Matter of time before there is a hole in the arm after I replace the sway bar bolt a few times. It just keeps rubbing as the suspension cycles over and over.

All because a jig was off when welding that bar in. Done my fair share of fabrication and understand how the process can be off a little. Hopefully they stand behind their products. The reason to buy such parts is to not be wasting time fabricating such things myself and focusing on the next adventure.

So here is Post #19 with larger pics.

"Short answer... sway bar rubbing a arm due to cross brace being welded about 1/4" off compared to other side.

Check email to your sales staff 24 Sep. Called and sent info, requested pics and measurements. I'll send reply email now so you can see fresh message."

Automotive tire Light Bicycle frame Bicycle fork Bicycle part
Hood Automotive tire Automotive lighting Bumper Automotive exterior
 

·
Registered
Joined
·
625 Posts
I see the problem. What is the desired outcome?
Last night I took pics of the contact being made when suspension cycles to make this issue easier to see. Please note the difference from left to right side clearance.

Left side where contact is happening.
Automotive tire Bumper Coil Gas Automotive exterior


Right side where I would say is normal clearance.
Cigar Material property Gas Tints and shades Thigh


I'm sure you can tell I have made a lot of effort to protect these arms. I keep all my rigs long term and keep records of all maintenance and repairs. The RS1 is no different. It will be mine for at least two decades if I'm still kicking.

Bought my first 2008 RZR 800 soon as they came out. Unit still plows my 300 yard steep grade gravel driveway all winter and looks like it's 4 years old at best. Rig is 14 years old!

I plan to order L&W radius rods for my TRE if this turns out well. Never seen any issues with L&W parts till now. This stuff happens. Everyone makes a mistake over time. Its how you deal with it that matters.

Expected Outcome is a replacement set of A-Arms. That way I can continue to use my RS1 until I am weathered out of riding this season, Jan/Feb. Then I can do a month of extensive winter maintenance and replace them as a pair. Be happy to send these back if shipping is paid for by L&W or other. Must say, I don't look forward to it. Will press in new bushings and the shop time doing double work is never a good thing. Going to cost me more time and money no matter what. Same can be said for L&W. I have been on both sides of this fence as a business owner myself.

Respectfully, I do appreciate your efforts and L&W. I hope this information is used to improve L&W parts. I have no reason to badmouth anyone in this process. I just want to correct the problem and get the high quality parts that I paid for and expected to receive.
 

·
craigstumph
Joined
·
13,601 Posts
Discussion Starter · #33 ·
My sales staff is attempting to help you. I am at UTV Takeover right now in St. George Utah. The pics have to go to L&W fab for resolution of the issue. I sent the pics tonight because my staff does not have access to the forum. I won't be back in the office for a few days and am answering forum questions as I get the opportunity. Here is the info L&W needs:

From L&W:
I will need some more information. Did they just now start hitting the sway bar, or have they been hitting for a year since he ordered them? Pictures would also be helpful so we can see where they are hitting.

Please work with my sales staff to resolve this and tell them I sent the pics to L&W.
 

·
Registered
Joined
·
625 Posts
My sales staff is attempting to help you. I am at UTV Takeover right now in St. George Utah. The pics have to go to L&W fab for resolution of the issue. I sent the pics tonight because my staff does not have access to the forum. I won't be back in the office for a few days and am answering forum questions as I get the opportunity. Here is the info L&W needs:

From L&W:
I will need some more information. Did they just now start hitting the sway bar, or have they been hitting for a year since he ordered them? Pictures would also be helpful so we can see where they are hitting.

Please work with my sales staff to resolve this and tell them I sent the pics to L&W.
Awesome place with trails high and low. Now I'm jealous!!

I appreciate your response. Sorry if I seem a little frustrated. I tried to work this through sales staff before and they never responded. That's why we are trying to hash this out on the forum.

I will respond to their request. Got to say though, it does feel like I'm getting the run around on a simple to understand problem.

Enjoy your trip. Wish I was there.
 

·
Registered
Joined
·
625 Posts
Back checking on emails this morning before we hit the trail. Is this a recent development or a long term issue with the bolt rubbing?
This is what I sent sales rep concerning when I noticed this contact was happening.

"I didn't install them until spring. Rough winter in Colorado and house repairs delayed my riding season and maintenance. They have been hitting since day one after install. I didn't notice it until I returned from a 3 week riding trip. Few days later I washed RZR and saw the damage. Still using the rig."

That's the meat of my response to sales about when contact was made. I can see the search for every possible cause other than L&W taking responsibility for the defect. I understand their thinking that my jig is perfect, we never make mistakes and QC guy will never admit something got by him. We are human. It does happen.

I have not hit or bent anything. The like new OEM arms had no issues. I wanted more ground clearance like TRE has and after seeing others bend so many of the thin stock lower arms and radius rods I decided to get ahead of that issue. There is no contact until suspension cycles. Not touching at ride height so you don't notice any problem except paint missing and notch worn into cross brace. When on the lift at full droop you have even more clearance as seen in those pics. It only hits because the cross brace is welded into place too far out. Measurements on the rig show this even without removing the arms. Every suspension part on my 2020 RS1 is OEM other than arms and skids.

I'm not a young kid out jumping gaps, playing in mud holes, bending frames and destroying equipment.
 

·
Registered
Joined
·
625 Posts
Thank you for responding and followup on this!!

Forgot to add that I sent all pics you have seen to sales even though you did same. I ask them to confirm they got the pics? No response from sales to confirm they got any of my emails.

Seems like I'm doing something wrong? Maybe they didn't get any of my emails on this issue from the start?
Sent them to:
[email protected]
 

·
Registered
Joined
·
625 Posts
I am not sure what is going on. I have searched by email ([email protected]) and order number (16739) without results. Here is the person you need to talk to. She has the pictures.

[email protected]
I see part of the problem. My emails from the house are forwarded to my brothers tablet in the shop. We respond from [email protected] and included the original email sent to stan.littleton1. We spend 90% of our time in the shop or on the trails. Tablet with 3 GPS receivers is always with us for navigation and communication when we have service.

I did explain that in email to sales along with providing phone contact info.

Thanks for response. I will contact Brooke. Does that mean you are out of the loop and handing me off to L&W?
 

·
craigstumph
Joined
·
13,601 Posts
Discussion Starter · #40 ·
I see part of the problem. My emails from the house are forwarded to my brothers tablet in the shop. We respond from [email protected] and included the original email sent to stan.littleton1. We spend 90% of our time in the shop or on the trails. Tablet with 3 GPS receivers is always with us for navigation and communication when we have service.

I did explain that in email to sales along with providing phone contact info.

Thanks for response. I will contact Brooke. Does that mean you are out of the loop and handing me off to L&W?
She needs the information about the problem originating from the time you received the product or if it was a recent development. I can relay it if you like. But I do need the information to get there.
 
21 - 40 of 43 Posts
Top