Polaris RZR Forum - RZR Forums.net banner

1 - 20 of 35 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter #1
Hi

My name is Facundo, and I live in Chile.
Yesterday I started to install my Turbo from K&T (thanks Kam from KBR).
I want to share some pictures from the installation. (The kit was Great).



































 

·
Premium Member
Joined
·
543 Posts
Thank's for sharing the pitures with us.
 

·
Premium Member
Joined
·
425 Posts
Facundo,
If I can be of any help, please ask.
Thanks again for the business and posting the pics.
Kam
 

·
Registered
Joined
·
29 Posts
Discussion Starter #7
Thanks Kam

I recived 2 Air Filter. one is an K&N, and other is a Wet Filter.
Wich one is better for Sand? and Wich one is better for trails (some water and Mud)

Also I recived a piece of black plastic, but I don't know where I must install.

Do I need some calibration of the turbo?
how much boost I must use?

Today I will continue the installation and the pictures.
 

Attachments

H

·
Guest
Joined
·
0 Posts
Thanks Kam

I recived 2 Air Filter. one is an K&N, and other is a Wet Filter.
Wich one is better for Sand? and Wich one is better for trails (some water and Mud)

Also I recived a piece of black plastic, but I don't know where I must install.Do I need some calibration of the turbo?
how much boost I must use?

Today I will continue the installation and the pictures.
Looking good! I started mine this morning.
The plastic piece is a rock gaurd for the intercooler..I haven't gotten that far yet..so I'm not sure exactly how it goes but knowing what it is I bet you can figure it out.
 

·
Premium Member
Joined
·
814 Posts
Thanks Kam

I recived 2 Air Filter. one is an K&N, and other is a Wet Filter.
Wich one is better for Sand? and Wich one is better for trails (some water and Mud)

Also I recived a piece of black plastic, but I don't know where I must install.

Do I need some calibration of the turbo?
how much boost I must use?

Today I will continue the installation and the pictures.
The K&N is for the air filter and wet filter (uni) is for the clutch cover.

The black plastic is for the intercooler its a protective cover.

No calibration is needed. You might need to adjust the fuel controller.
And 9 Ibs is good.

and the manifold is upside down for the third injector it should be facing down.
 

·
Registered
Joined
·
29 Posts
Discussion Starter #10
Thanks Kam

I recived 2 Air Filter. one is an K&N, and other is a Wet Filter.
Wich one is better for Sand? and Wich one is better for trails (some water and Mud)

Also I recived a piece of black plastic, but I don't know where I must install.

Do I need some calibration of the turbo?
how much boost I must use?

Today I will continue the installation and the pictures.
The K&N is for the air filter and wet filter (uni) is for the clutch cover.

The black plastic is for the intercooler its a protective cover.

No calibration is needed. You might need to adjust the fuel controller.
And 9 Ibs is good.

and the manifold is upside down for the third injector it should be facing down.
Thanks for the answers.
I moved the third injector because it not fit on my RZR, my fuel rail is too low, I will take a picture. may be you can help me to solve this.
 
H

·
Guest
Joined
·
0 Posts
Thanks Kam

I recived 2 Air Filter. one is an K&N, and other is a Wet Filter.
Wich one is better for Sand? and Wich one is better for trails (some water and Mud)

Also I recived a piece of black plastic, but I don't know where I must install.

Do I need some calibration of the turbo?
how much boost I must use?

Today I will continue the installation and the pictures.
The K&N is for the air filter and wet filter (uni) is for the clutch cover.

The black plastic is for the intercooler its a protective cover.

No calibration is needed. You might need to adjust the fuel controller.
And 9 Ibs is good.

and the manifold is upside down for the third injector it should be facing down.
Thanks for the answers.
I moved the third injector because it not fit on my RZR, my fuel rail is too low, I will take a picture. may be you can help me to solve this.
That is a new style manifold..the injector comes out the bottom. You need to put the injector back like it came and remount the manifold with the injector coming out the bottom. ie unbolt it from the head rotate it 180* and bolt it up.
 

·
Registered
Joined
·
15,386 Posts
It looks like you ride in a muddy area. You might want to consider upgrading to the water to air intercooler if the air to air fan gets pugged with mud all the time.
I only ride in the sand dunes, but for the mudders the water to air looks like the way to go.
 
H

·
Guest
Joined
·
0 Posts
Thanks Rod and Mike!
Having good customers rules!
It's all good..
This is the first time I have ever been in the shop installing something..had my cell phone ring..wonder who the hell is this bothering me..and it be the guy who makes the product I am installing calling to ask me how it was going!:headbang:

Some guy named Rayce? :rofl3:
 

·
Registered
Joined
·
29 Posts
Discussion Starter #16
Thanks a lot guys.

Now I understad and solved the Manifold problem :)

Also I conected the wires.

I can't figure where is mounted the shield protector, but I will still trying. any one have a picture?
 

Attachments

H

·
Guest
Joined
·
0 Posts
Thanks a lot guys.

Now I understad and solved the Manifold problem :)

Also I conected the wires.

I can't figure where is mounted the shield protector, but I will still trying. any one have a picture?
Haven't mounted mine yet..but I have a pic coming or how I am pretty sure it goes...
K&T have made some recent improvements to the kit and are working on getting the instructions updated.
For us guys in the US we get topnotch phone support so it's no big deal.
Thankfully K&T called me and told me of the changes before I even ran into anything that wasn't in the instructions.
 

·
Registered
Joined
·
29 Posts
Discussion Starter #19
Thanks for the picture.

I started the engine!!!

But I have 2 problems.

-Oil leak from the muffler. any idea??
-fuel leak from the tank.
 
H

·
Guest
Joined
·
0 Posts
Thanks for the picture.

I started the engine!!!

But I have 2 problems.

-Oil leak from the muffler. any idea??
-fuel leak from the tank.
Is the oil actually leaking out of the muffler? Or is it coming from one of the oil lines for the turbo..
If it is actually running out of the muffler look at how your return line(bottom line) is routed and make sure it isn't kinked and is routed in a general doward direction to the drain at the dipstick tube. If it is leaking from one of the hoses then maybe the clamp needs to be tighter?

Fuel leak at the tank...where at specifically? At the return barb? If so again..check your clamp.
 
1 - 20 of 35 Posts
Top