Polaris RZR Forum - RZR Forums.net banner

1 - 7 of 7 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1 (Edited)
2012 and it's sputtering, backfiring, stalling out at idle, but seems to run ok under load. I just had it in for a complete go through at the dealership. The did the routine warranty check up, replaced the diff fluids, oil, filter, and spark plug change. The last time I drove it, it idled fine. Started it up yesterday, and it's a mess. I pulled the plugs, left bank was black, the right bank was half black, and tan, both are getting spark with the key. Ideas?
 

·
Registered
Joined
·
19 Posts
Discussion Starter #2
Did a lot of research, I even swapped plugs from side to side to see if it follows, it did not. Still right bank is where the backfire is coming from. I suspect possibly a plug wire, it's 0200 right now, and no one up to hit the key for me to check spark again. IIRC, one side had a weaker spark. So, that would either mean plug, plug wire, or ignition. Don't expect an answer at this time of night, just trying to give as much info as I can. Need to get this running, it might be at least another month before the shop opens up. I seen the presidents speach today, he says another month of quarantine, up to states though, not trying to count on any of them...
 

·
Registered
Joined
·
508 Posts
What the heck do I know, but usually simply spark/ignition issues are worse under load. not alway though, so...

any chance they balled up the firing orde/got plug wires reversed?

any codes?

change fuel?

does one bank have a unique air path from the filter? Something blocking or restricting that?
 

·
Registered
Joined
·
19 Posts
Discussion Starter #4
It ran great when I got it back from the shop. Wires are in correct order, no codes, checked the air filter, nothing restricting air flow, even checked the two air tubes for blockage, they are OK. Thanks for trying to help.

Keep the ideas coming, hopefully we can find the issue...
 

·
Premium Member
Joined
·
337 Posts
Try spraying starter fluid if itt isles fine injectors could be clogged how long has it been sitting before you took it to the shop


Sent from my iPhone using RZRForums.net
 

·
Registered
Joined
·
19 Posts
Discussion Starter #6
I took some video earlier of the spark on each cylinder, and when it would try and idle. I was thinking injector as well. It's going to be a royal pain to get to them it seems< unless someone knows a short cut?

I'll post the video in a few...
 

·
Registered
Joined
·
19 Posts
Discussion Starter #7
Can't find a link to post video.. But it is stuttering all through the RPM range, and still backfiring in the right bank only...
 
1 - 7 of 7 Posts
Top