Polaris RZR Forum - RZR Forums.net banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
My 2014 Polaris rzr 900 xp fan is acting up I will be riding it and it works fine like 4 to 5 times then after that it’s like it will short out and stop working we read that a lot of people said it’s the rectifier and we replace that and it working as good as new for two days then I was in the middle of a ride and it did it again I need help idk what to do
 

·
Registered
Joined
·
517 Posts
check:
relay
fan motor
sensor
wiring
 

·
Registered
Joined
·
361 Posts
Diagnosing is usually better than throwing parts at it.

Does the fan operate properly when you allow vehicle to sit and idle for several minutes? Any unusual sounds? Any restrictions, debris, preventing the fan from rotating? Do you have a service manual? Test light? DVOM?

The following is from a 2011 900xp service manual:

1. Disconnect harness from coolant temperature sensor on the engine cylinder head (see Chapter 4 for location).
2. With the transmission in Park, start the engine. After a few seconds, the fan should start running and the "Check Engine" indicator should display on the instrument cluster. This indicates all other components are working properly.
3. If the fan does not run or runs slowly, check the fan motor wiring, ground, motor condition and mechanical relay for proper operation. Repair or replace as necessary. If the fan runs with the sensor harness disconnected, but will not tum on when the engine is hot, check the coolant temperature sensor and connector terminals.
 
1 - 3 of 3 Posts
Top