Polaris RZR Forum - RZR Forums.net banner

1 - 17 of 17 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter #1
2011 RZR S 80 miles.
Started it up to load it for a trip to Glamis tonight.
Im getting a loud Clicking / knocking noise from the engine, seems like its on the top end. It speeds up with RPM.

I dont know a lot about these engines but it doesnt sound good.
Any clues if it may be something the dealer can adjust in a short amount of time or does it sound like a larger repair job.

Im supposed to leave in the morning for a 10 day dune trip.
Errrrrr!!
 

·
Registered
Joined
·
15,386 Posts
I dont know about the 2011 engine,,, but the older engines are known for valve tick if the oil level is low.
Did you check the oil level yet?
 

·
Force it
Joined
·
75 Posts
screwed sounds like a valve
 

·
◄►STARS & STRIPES◄►
Joined
·
3,832 Posts
:attention1:TTT:attention1:

Keep her at the top till we get some wrenchers on here to help you out....Otherwise I would be at the dealership 15 min prior to it opening.....Hope you get her fixed!!
 

·
Registered
Joined
·
44 Posts
Discussion Starter #6
Appreciate the help. I will be at the dealership first thing.
Thought someone would be able to eather help me sleep better or tell me to go drink :D

It is odd. I had it out last weekend and didnt hear it. Start it up and clack clack clack
 

·
◄►STARS & STRIPES◄►
Joined
·
3,832 Posts
Appreciate the help. I will be at the dealership first thing.
Thought someone would be able to eather help me sleep better or tell me to go drink :D

It is odd. I had it out last weekend and didnt hear it. Start it up and clack clack clack
I dont know how your local polaris shop is in the way of "customer service" But I know at least where I'm from, That if they see me standing there before they drive up...I'm gonna get some help....Doesnt matter whats on the schedule..I think if you explain "hey this is the situation" about your trip....They'll get you in and out..I hope...now $$ ??
 

·
Registered
Joined
·
31 Posts
i have a 2010 rzrs the day i was braking it in first time really riding it was 4 days old it started to make a cliking/knoking noise it was coming from the vavle cover ran it to the dealer it was closing time so they didnt do much the nexst day called at 9am and they had just started on it they called me back at 12pm said come get it (fixed) they did not know what it was fixed it sellf just let it run and drove it around in the parking lot did the trick hope the helps
 

·
Registered
Joined
·
311 Posts
i have a 2010 rzrs the day i was braking it in first time really riding it was 4 days old it started to make a cliking/knoking noise it was coming from the vavle cover ran it to the dealer it was closing time so they didnt do much the nexst day called at 9am and they had just started on it they called me back at 12pm said come get it (fixed) they did not know what it was fixed it sellf just let it run and drove it around in the parking lot did the trick hope the helps
Did they charge you $200.00 to drive it around the parking lot? Sounds like something my dealer would do. I wouldnt trust my dealer to put air in my tires. Hope you get it sorted out. Im guessing its the belt also..let us know.
 

·
◄►STARS & STRIPES◄►
Joined
·
3,832 Posts
Wow, you guys have some horrible stories..Our shop up here (POLARIS) prides itself on honest hard work..they will show you everything!! if somethings wrong, a parts broke or worn... they even take mounting and balancing tires seriously!! I remember going in for my "first" oil change after literally only 12 hours on my first Polaris ATV, I got called 30 minutes later and was told "Mr. Waszak, We pulled the filter checked the oil ect..it was so clean and new we wouldnt even change it and charge you..we also added new oil for the oil that was lost during the inspection. No charge come and get your baby"! Had the same amount of hours on my Brand new YAMAHA Grizzly, I returned to the shop (YAMAHA) for a $230 bill, same oil filter (I mark them) and oil never changed and they said it needed this and that not covered under warrentee....Ended up paying nothing after showing them the OiL FILTER proof and embarressed them in front of about 6 customers in the store..Never went back....Years ago though..no more ATVs for me......Also drove by the other day...Eagle river Yamaha..Closed!! Geeee wonder why they went out of business!!
 

·
Force it
Joined
·
75 Posts
So What was the problem.
 

·
Registered
Joined
·
104 Posts
sounds like low oil to me, thats what mine was doin before it blew up.

brian
 
1 - 17 of 17 Posts
Top