Polaris RZR Forum - RZR Forums.net banner
1 - 20 of 98 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter · #1 ·
My transmission went down on my 2010. Polaris had paid for the parts but I have to pay $1200 for the labors. It's funny because the have a kit to replace the junk they installed at the factory but the denied it's a problem like the bad spring suspension! What a ripped???
 

·
Registered
Joined
·
3 Posts
i have a rzr4 and the transmission went down with it only a month old in july. atv zone in louisiana put the update kit in it and it didnt cost me a dime. the dealers can fully warranty it parts and labor if they want to.
 

·
Desert Rat
Joined
·
2,149 Posts
Yeah Vista, check some other dealers before you spend the $1,200.
 

·
Registered
Joined
·
819 Posts
Not having one in my garage just yet, is this something a person that has pulled apart motorcycle motors/trans etc. and put back together again could do? If there is some type of upgrade for it I'm wondering if they would just give it to me at the time of purchase and I would switch it out myself? I ain't scared :)
 

·
Registered
Joined
·
1,893 Posts
Not having one in my garage just yet, is this something a person that has pulled apart motorcycle motors/trans etc. and put back together again could do? If there is some type of upgrade for it I'm wondering if they would just give it to me at the time of purchase and I would switch it out myself? I ain't scared :)
If you buy new you wont have the problem as polaris did the upgrade to all models as of 5-2010
 

·
Desert Rat
Joined
·
2,149 Posts
Yeah, first I've heard of this one too. Curious what the kit is.
 

·
Registered
Joined
·
418 Posts
My 2010 S just broke the trans this last week when on vacation in Colorado. Its got 41 hrs and 360 miles on it. Broke going downhill letting the engine do the braking,
low and AWD engaged. Reverse still works but jumps out of low or high. I checked the manufacture date on the frame behind the RF shock and it says 7/10/09. So does it have the redesigned parts already installed at the factory? I can`t believe the belt is stronger than the trans. If it already has the so called better parts in it I think I`ll be selling this P.O.S. since the trans can`t be trusted to get you back to camp.
 

·
Registered
Joined
·
113 Posts
Not having one in my garage just yet, is this something a person that has pulled apart motorcycle motors/trans etc. and put back together again could do? If there is some type of upgrade for it I'm wondering if they would just give it to me at the time of purchase and I would switch it out myself? I ain't scared :)
If you buy new you wont have the problem as polaris did the upgrade to all models as of 5-2010
Not True,

I bought new about 30 days ago. Mine was built late Dec 2009 :(
 

·
Registered
Joined
·
225 Posts
Not having one in my garage just yet, is this something a person that has pulled apart motorcycle motors/trans etc. and put back together again could do? If there is some type of upgrade for it I'm wondering if they would just give it to me at the time of purchase and I would switch it out myself? I ain't scared :)
If you buy new you wont have the problem as polaris did the upgrade to all models as of 5-2010
Not True,

I bought new about 30 days ago. Mine was built late Dec 2009 :(
Could still be true if 5/2010 is the build date.

Frightening how many issues Polaris is still having.
 

·
Registered
Joined
·
71 Posts
What is the nature of the problem? My 2010 S has a build date of 3/25/10, and now has 1560 miles on it. If there is a problem with the tranny on pre-May 2010, what symptoms does it typically have?
 

·
Registered
Joined
·
71 Posts
Thanks, Kevin. None of that so far, so maybe I got lucky! On the flip side, this weekend I noticed it starting to make a sort of ticking sound when going downhill using engine braking. Louder in low than high. Might also be an exhaust leak, but check that.
 

·
Registered
Joined
·
80 Posts
mine went down over a month and a half ago, just got the parts...

2010 S, just out of warranty.. polaris will not give me a reason why they discontinued the 2010 parts and have the "upgraded" kit. I already know why, but I want to hear why polaris mysteriously recognized the problem, comes out with a fix but won't cover the rzrs with the old part numbers that are a ticking time bomb. its only a matter of time before rzr owners 2010 prior to 5-17-2010 manufacture date will have problems. Maybe we should start a posting how many hrs and miles we had when they went down. from the other owners i have read about its been about 35-40 hrs and almost 500 miles before they pop. also usually breaks in AWD and L. Mine did.
 

·
Registered
Joined
·
693 Posts
There was a guy a few months ago posting about a similar problem with a 2010 rzr. He went on quite a rant as I recall. Claims to have been banned from here because of his "negativity", which I find very hard to believe. Has posted his saga on another website (still recommends this one though) detailing his lemon law proceedings in texas. Last post was on 7/7/10 with no resolution.

If you have a 2010 Polaris RZR built prior to 5-17-2010 - Topic Powered by Social Strata
 

·
Registered
Joined
·
1,893 Posts
Not having one in my garage just yet, is this something a person that has pulled apart motorcycle motors/trans etc. and put back together again could do? If there is some type of upgrade for it I'm wondering if they would just give it to me at the time of purchase and I would switch it out myself? I ain't scared :)
If you buy new you wont have the problem as polaris did the upgrade to all models as of 5-2010
Not True,

I bought new about 30 days ago. Mine was built late Dec 2009 :(
Well if you look above the right front wheel on the build date sticker and buy one that is built after 5-2010 then:rofl3:
 
1 - 20 of 98 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top