Polaris RZR Forum - RZR Forums.net banner

1 - 12 of 12 Posts

·
tinytimslaw2
Joined
·
377 Posts
Discussion Starter #1
2008, My trans is very hard to shift, it will shift thru all positions, is just extremely hard, I have disconnected the cable, on the side of the trans and the cable moves easily. The trans shifter arm, on the side of the trans moves thru all the positions but is very hard to move.
I would be grateful for any suggestions. Tim
 

·
Registered
Joined
·
880 Posts
Tim, you say it's a 08? Is it hard between all positions or just getting out of park and/or high? Is it a lot easier without the engine running?
You can remove the detent ball & spring on the left (driver's) side of the case if it's still in there. But be prepared to drain fluid if you drop the ball inside.
 

·
Ballzout
Joined
·
1,035 Posts
If you ride in alot of mud your cable is probably caked full of silt. That happened to mine and i had to order a new cable.
 

·
tinytimslaw2
Joined
·
377 Posts
Discussion Starter #5
Tim, you say it's a 08? Is it hard between all positions or just getting out of park and/or high? Is it a lot easier without the engine running?
You can remove the detent ball & spring on the left (driver's) side of the case if it's still in there. But be prepared to drain fluid if you drop the ball inside.
Stumpduster, running or not, it's hard, hard between all the positions, cable is smooth, where at on drivers side case is the detent ball and spring? I think I'll remove it. Thanks Tim
 

·
Registered
Joined
·
880 Posts
It's behind the bolt just above the linkage. There is a inner bolt inside a sleeve bolt, you want to remove the inner bolt only. After extracting the spring you can look into the hole ... if you can see the shift plate with the detent holes moving inside while shifting into different gears the ball is missing! If the ball is in place, a dab of grease on the end of probe of some sort should be able to extract it. But with the tension off the spring you should notice eaiser shifting already.
A search for "remove detent ball" brings up a few but here is one you may want to read thru http://www.rzrforums.net/general-rzr-discussion/26868-rzr-hard-shift-3.html
 

·
tinytimslaw2
Joined
·
377 Posts
Discussion Starter #7
It's behind the bolt just above the linkage. There is a inner bolt inside a sleeve bolt, you want to remove the inner bolt only. After extracting the spring you can look into the hole ... if you can see the shift plate with the detent holes moving inside while shifting into different gears the ball is missing! If the ball is in place, a dab of grease on the end of probe of some sort should be able to extract it. But with the tension off the spring you should notice eaiser shifting already.
A search for "remove detent ball" brings up a few but here is one you may want to read thru http://www.rzrforums.net/general-rzr-discussion/26868-rzr-hard-shift-3.html
Thanks, I'll remove it when I get home, take care. Tim
 

·
tinytimslaw2
Joined
·
377 Posts
Discussion Starter #8
I removed the detent ball and it didnt get any easier, I unhooked the shift cable, cable moves freely, not parked on hill....any other ideas? Tim
 

·
Vendor
Joined
·
4,174 Posts
My 08 now has become hard too. I removed the LH spring and detent ball and it helped, but is still much harder than my other RZR. My fathers 09 S model is smooth as silk. I am wondering if the RH spring or spring bolt is different in length. Anyone know if this is true? Next question, I am wondering why it has gotten hard to shift? Makes me wonder if there is a problem coming on? I have unhooked the cable to do the testing and it is still hard shifting. Anyone else run into this?
 

·
Registered
Joined
·
710 Posts
I have an 08 and it had the same problem it got progrssively harder to run through the gears, especially when i was trying to get out of park on incline. What is odd, I think I snapped the linkage this last weekend and now it will not go into park, but it is now easier to get into the rest of the gears? I dont know if that will help shed any light on the OP's issue, but I put a parking brake on it and calling it good for now.
 

·
Registered
Joined
·
309 Posts
I ran into the same problem with my old 09 S, got a new cable and it worked smoothly again. Cost me around $100. I still have the newer cable as my frame got twisted. $40 shipped to anywhere.
 

·
Vendor
Joined
·
4,174 Posts
I took the spring and ball detent off the driver's side and that fixed the problem. So, will go with that for now and see how it works out.
 
1 - 12 of 12 Posts
Top