Polaris RZR Forum - RZR Forums.net banner

1 - 6 of 6 Posts

·
timbest
Joined
·
20 Posts
Discussion Starter #1
There is a rattle coming from my driveshaft. Happens during deceleration when the torque is relieved in the drive line. Didn't notice it before I pulled driveshaft during engine replacement. Anyone think this indicates problem or is this standard operating noise? Noise doesn't bother me but an ounce of prevention.......
 

·
Registered
Joined
·
3,475 Posts
Its either the front or rear yoke, normally the front, or bad u-joints or all of the above. I've replaced everything on our's. It's about time to do it again. I recommend drilling and tapping the front yoke perpindicular to the roll pin, then installing set screws to keep the yoke from wiggling back and forth on the roll pin. I aslo replaced the roll pin with a grade 8 5/16" bolt.
 

·
Registered
Joined
·
83 Posts
First thing I would do is check the u joints and carrier bearing. As shipped from the factory mine were all toast in less than 500 miles. Grease everything including your yokes.
 

·
Registered
Joined
·
3,475 Posts
First thing I would do is check the u joints and carrier bearing. As shipped from the factory mine were all toast in less than 500 miles. Grease everything including your yokes.
2012 800's don't have carrier bearings like the newer machines.
 

·
timbest
Joined
·
20 Posts
Discussion Starter #5
Thanks for the input! I didn't notice excessive play in u joints or slip yokes when I had It out couple mouths ago but I guess it has to be one or all of them.....I better have a more in depth look!
 

·
Registered
Joined
·
3,475 Posts
Thanks for the input! I didn't notice excessive play in u joints or slip yokes when I had It out couple mouths ago but I guess it has to be one or all of them.....I better have a more in depth look!
Yea I've been down that road a few times in the 5000 miles we've put in our 800S.
 
1 - 6 of 6 Posts
Top