Polaris RZR Forum - RZR Forums.net banner
1 - 10 of 10 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
I am new to the Rzr and have read tons of posts about the intake letting dirt past. It seems like this was fixed by the 2010's with a new filter?? Is anyone still having issues? I'd hate to grenade my new 2011.

Thanks
 

·
Registered
Joined
·
909 Posts
I have an '09. but I would check the connections at the air box/throttle body, that seems to be an issue. If you don't want to buy a new intake setup , definetly check the throttle body area and the rubber boot for any signs of dust. In my group of 4 '09's, 2 of us had dust and 2 didn't! I installed an UMP and never had another problem.
Good luck and have fun!
 

·
King of crash!
Joined
·
31,881 Posts
that qyestion depends on who you talk too....some say yes and some say no..... best thing is to ck it over and keep a eye on it.... or just swap out a new air box like most people do anyways.... more air is always better.
 

·
Registered
Joined
·
901 Posts
I have about 34 hours and 500 miles on mine. 95% of that riding was in very dusty conditions. Tonight I pulled the bed and took my intake out to the TB. I didn't find any dust past the filter. I'm still planning on installing a new intake/filter set-up.
 

·
Registered
Joined
·
36 Posts
I have about 34 hours and 500 miles on mine. 95% of that riding was in very dusty conditions. Tonight I pulled the bed and took my intake out to the TB. I didn't find any dust past the filter. I'm still planning on installing a new intake/filter set-up.
Roughly the same scenario for me. Removed the bed to do some maintenance and found no dust past the filter. All is well.
 

·
Registered
Joined
·
1,383 Posts
I had a 08 that had the problem / top end rebuilt. I now have a 2009 S, although the TB is clean with the stock filter I am doing the Grumpy air mod.

The Grumpy air mod prefilters the air to the CVT and then engine. My thought is if you prefilter the majority of the dust then the stock air filter should be enough plus less wear on cvt and you keep the belt cooler with more air.
 

·
rjse
Joined
·
17 Posts
My 2010s did but a lot of other ones did not. The best thing you can do is after your first ride and with the engine OFF and key ON pull the filter and have someone stand on the accelerator and look down the throttle body with a flashlight to see if there is any dust. Mine was not leaking past the filter but past the boot between the filter and throttle body. Better safe than sorry. I have not seen any new posts about the problem for a while so maybe it is finally resolved.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top