Polaris RZR Forum - RZR Forums.net banner

1 - 20 of 21 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
Dealer just replaced the primary clutch and rzr is now tough shifting between gears and when put into reverse the rzr jumps backwards or when put into high or low gear the rzr jumps forward. Is this normal?
 

·
Registered
Joined
·
141 Posts
Not sure if this is related to the primary being torqued to high or not but hard shifting was an issue many of us had with our new turbo s machines. What worked for myself and many others way to pull the primary off and reinstall it with proper torque spec. I can’t remember off the top of my head what the spec was.


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
616 Posts
Dealer just replaced the primary clutch and rzr is now tough shifting between gears and when put into reverse the rzr jumps backwards or when put into high or low gear the rzr jumps forward. Is this normal?
Curious, why did the dealer replace the clutch?
 

·
Registered
Joined
·
17 Posts
Discussion Starter #5
Dealer just replaced the primary clutch and rzr is now tough shifting between gears and when put into reverse the rzr jumps backwards or when put into high or low gear the rzr jumps forward. Is this normal?
Curious, why did the dealer replace the clutch?
A piece of the guide broke off that the primary clutch moves on. Heard a like metal grinding noise so took the clutch cover off and started the rzr, with the rzr in park gave it a little gas and this small piece of like sheet metal cane flying out. Polaris said the primary clutch was on backorder till middle of May and rzr was fixed about a week ago. According to iron city polaris sent them a new clutch with a different part number.
 

·
Premium Member
Joined
·
78 Posts
Dealer just replaced the primary clutch and rzr is now tough shifting between gears and when put into reverse the rzr jumps backwards or when put into high or low gear the rzr jumps forward. Is this normal?
Curious, why did the dealer replace the clutch?
A piece of the guide broke off that the primary clutch moves on. Heard a like metal grinding noise so took the clutch cover off and started the rzr, with the rzr in park gave it a little gas and this small piece of like sheet metal cane flying out. Polaris said the primary clutch was on backorder till middle of May and rzr was fixed about a week ago. According to iron city polaris sent them a new clutch with a different part number.
The sliders? My sliders broke and I found pieces attached to my magnetic weights on my aftermarket arms. Asked my dealer and he said he hadn’t heard of any other problems with sliders breaking.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #8
Curious, why did the dealer replace the clutch?
A piece of the guide broke off that the primary clutch moves on. Heard a like metal grinding noise so took the clutch cover off and started the rzr, with the rzr in park gave it a little gas and this small piece of like sheet metal cane flying out. Polaris said the primary clutch was on backorder till middle of May and rzr was fixed about a week ago. According to iron city polaris sent them a new clutch with a different part number.
The sliders? My sliders broke and I found pieces attached to my magnetic weights on my aftermarket arms. Asked my dealer and he said he hadn’t heard of any other problems with sliders breaking.

Going to be taking back to the dealer will keep everyone posted on new info.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #9
Well here is what happened after trying to take my rzr back. From the beginning Took my 2019 turbo s 4 rzr in about three weeks ago because I was hearing a clunking noise coming from the front end only while in 4x4. I could switch into 2x4 and the noise would go away and come back on 4x4. So iron city replaced the whole front diff and noise was gone. Got rzr home and noticed the front diff was leaking which looked like grease where the axel goes into the front diff on driver side. Wiped it off and waited to go on a ride to see if the grease came back. Ended upcoming wiping grease off three times and still coming back. Started the rzr after getting back home from shop and heard a funny noise now coming from the clutch, gave it a little gas in park and now the noise got worse sounding like metal grinding. Took the cover off, started the rzr gave it a little gas in park and a piece of metal came flying out of the clutch housing onto the ground. Took rzr back, iron city ended up replacing the primary clutch. Got rzr back and now it was making a loud like humming noise in park and neutral, noise would go away when put into gear. But when put into gear like reverse the rzr jumps back or if put into forward the rzr jumps forward. Dave the guy I was dealing with told me it was normal with a new clutch and to put 30 miles on it to break it in and all that would go away. This isn’t my first rzr didn’t think that was right so anyway took it on a 40 mile ride as suggested and still the same issues leaking front end and issues with clutch. Took rzr back to shop and Dave said there was nothing he could do about the front diff leaking because Polaris wouldn’t pay him to investigate why it was leaking even though he just put the new diff in. So I asked if I should take rzr to different shop that was willing to fix a leaking front diff that was just put in. Dave said if I would have bought my rzr from him they would have had marge to investigate rzr without getting paid by Polaris to look at it. I asked Dave to put the rzr from park into reverse so I could get a video of the noise the clutch was making for my records. He threw a fit and told me to take the rzr to a different shop and that he would not help me. I do not recommend taking anything to iron city Polaris.
 

·
Premium Member
Joined
·
636 Posts
Clutch issues are a real thing in the 2019 xpt and turbo s. A buddy of mine just bought a new velocity s and it spit the clutch cover bearing out and tossed it around the case with 13 miles on the odometer. Was only heat cycles in the yard with the tits still on the tires. Polaris had to replace everything. Belt case plastic cover, complete primary, complete secondary and belt. Here is a pic of the bearing it spit out from the aluminum clutch cover
 

Attachments

·
Registered
Joined
·
21 Posts
This weekend I changed my clutch springs and weights as I’m running a 35” tire. Please know I’ve yet to use my RZR Turbo 4 S with 35” tires and I’m trying to stay ahead of the game. Upon taking everything apart I found on the secondary clutch 1 of 3 helix buttons were broke. Luckily the dealer had them so I replaced all 3. Then on my primary I found all 3 sliders broke, there was nothing I could for those as I didn’t have the tool to change them. I put it all back together and it seems to be fine for now. What do you think could be causing this? My car is also very hard to shift and it’s been this way since day 1. When I had everything apart I reinstalled the primary and torqued it to proper specs. Car only has 350 miles on it.
 

·
Registered
Joined
·
750 Posts
This weekend I changed my clutch springs and weights as I’m running a 35” tire. Please know I’ve yet to use my RZR Turbo 4 S with 35” tires and I’m trying to stay ahead of the game. Upon taking everything apart I found on the secondary clutch 1 of 3 helix buttons were broke. Luckily the dealer had them so I replaced all 3. Then on my primary I found all 3 sliders broke, there was nothing I could for those as I didn’t have the tool to change them. I put it all back together and it seems to be fine for now. What do you think could be causing this? My car is also very hard to shift and it’s been this way since day 1. When I had everything apart I reinstalled the primary and torqued it to proper specs. Car only has 350 miles on it.
Why not just take it to the dealer and let them deal with it? Obviously something was not right from day 1 if it was hard to shift. Clutches need to be checked for alignment and made sure they seated correctly. Sucks to have clutch issues hopefully you get it figured out
 

·
Registered
Joined
·
21 Posts
This weekend I changed my clutch springs and weights as I’m running a 35” tire. Please know I’ve yet to use my RZR Turbo 4 S with 35” tires and I’m trying to stay ahead of the game. Upon taking everything apart I found on the secondary clutch 1 of 3 helix buttons were broke. Luckily the dealer had them so I replaced all 3. Then on my primary I found all 3 sliders broke, there was nothing I could for those as I didn’t have the tool to change them. I put it all back together and it seems to be fine for now. What do you think could be causing this? My car is also very hard to shift and it’s been this way since day 1. When I had everything apart I reinstalled the primary and torqued it to proper specs. Car only has 350 miles on it.
Why not just take it to the dealer and let them deal with it? Obviously something was not right from day 1 if it was hard to shift. Clutches need to be checked for alignment and made sure they seated correctly. Sucks to have clutch issues hopefully you get it figured out
I’m sure now that I’ve messed with it the warranty is void? I’m going to call today and see what they say..
 

Attachments

·
Premium Member
Joined
·
636 Posts
Is you aluminum primary clutch cover bearing still in place? This is the same thing that happened to my buddy's 19 velocity with 13 miles. It broke the plastic sliders in the primary after that bearing took a shit that rides on the spider. Then the pieces flying around in the case messed up parts in the secondary
 

Attachments

·
Registered
Joined
·
21 Posts
Is you aluminum primary clutch cover bearing still in place? This is the same thing that happened to my buddy's 19 velocity with 13 miles. It broke the plastic sliders in the primary after that bearing took a shit that rides on the spider. Then the pieces flying around in the case messed up parts in the secondary
Everything is OK, all looked brand new with the exception of these broken plastic pieces. I don’t know what’s causing them to break. I’m going to call a local dealer and talk to them about service.
 

·
Registered
Joined
·
2 Posts
e 900xp 4 my belt was burned
Replaced it but having problems with shifting when car is on shinfter is hard shifting, when cars is off shifting is easy
Need help to figure out before Memorial Weekend
 

·
Vendor
Joined
·
10,238 Posts

·
Registered
Joined
·
21 Posts
Any update with this? I just took mine apart and changed the sliders but the spider seems to have excessive movement but I don’t know what’s right or wrong.

FYI - I called 2 local dealers and they both said those plastic parts are normal wear and tear and they have gotten no warranty from Polaris regardless of the miles.

The bearing looked good and all other parts look good, I guess I’ll put it back together and when it blows up I’ll take it in?
 
1 - 20 of 21 Posts
Top