Polaris RZR Forum - RZR Forums.net banner

1 - 11 of 11 Posts

·
Registered
Joined
·
262 Posts
Discussion Starter #1
Took my Turbo S out for the first time this past weekend and noticed a clunking noise when going over mild bumps. Sounded like some loose in the storage box but it was not. I opened the little access cover between the seats to the engine and the noise was louder. Did not sound like metal to metal just a clunking noise of something loose. Appreciate any thoughts on what it might be. Also had some major squeaking but think that is the rear sway bar?
 

·
Premium Member
Joined
·
1,928 Posts
I would suspect your rear sway bar is making the clucking noise as well . Check the bushings and links for wear
Also take a good look at the motor mounts and bar
 

·
Registered
Joined
·
262 Posts
Discussion Starter #4
Thanks guys.......I will check both the sway bar and the motor mounts.
 

·
Registered
Joined
·
262 Posts
Discussion Starter #7
Grab the sway bar and pull and shove it left to right.

It's the sway bar.
I shoved the sway bar and it clunked left to right. I assume that it should not really move left to right easy like it did. So do I need to replace bushings then? Or the entire bracket? Thanks for your help!
 

·
Registered
Joined
·
46 Posts

·
Registered
Joined
·
262 Posts
Discussion Starter #9

·
Registered
Joined
·
422 Posts
I picked 2 of those clamps up and noticed when putting it on, it is at an angle on the bar due to being near the corner. Would that not damage the bushing when the bar went up and down by pressing against it? If it was straight on the bar that would not happen.
I'm at work and cant look at my Turbo S, but I remember on my XP900, there were collars like these on the sway bar as well. I thought they were between the mounts, not outside.

Either way, it may be possible to put the collars on the Turbo S Sway bar just inside the mounts so they are on a straight part of the bar.
 

·
Registered
Joined
·
607 Posts
pic of my rear swaybar. although its a 2017 xp4 1000. should be similar to the xp900. for the S version, im not sure.
its dirtly like that as i grease them for service often.
.
652207
 
1 - 11 of 11 Posts
Top