Polaris RZR Forum - RZR Forums.net banner

1 - 13 of 13 Posts

·
Registered
Joined
·
250 Posts
Discussion Starter #1
Ok we went riding last weekend on the piute trail. Well the trail was really tight and slow. My check eng. Light came on so I pulled over and shut it off. After a few minutes I turned it on and the light was gone. Was it just hot or something else?
 

·
Registered
Joined
·
15,386 Posts
you can ignore 26, it is for international RZRs with turf mode differentials..

I would say it was just probably just low voltage from going slow for a while... low rpms = low amperage from the stator.

keep an eye on it and see if it happens again.

check my signature for free downloads that will help in the future.
 

·
Registered
Joined
·
15,386 Posts
no problem,

and to answer your question about the engine being hot... if it does get too hot the display with flash and say "hot". so that wasn't the issue.
 

·
Registered
Joined
·
860 Posts
WOW, great info. Thanks Clifford.
I am a auto tech and that is the same way you pull flash codes on a chrysler product.
 

·
Registered
Joined
·
250 Posts
Discussion Starter #9
One more question..... my 6 month warranty runs out on the 20th of this month. Would you spend the $900 for a 5 year one?
 

·
Registered
Joined
·
15,386 Posts
hmm,, that is a tough one. probably not... but I am the kind of guy that would put a turbo on it and modify it to the point that warranty claims would be denied! LOL

If you have been riding it and nothing has broken yet, then it is probably ok and free from manufacturing defects.

But if you are going to leave it stock and want peace of mind,,, is it worth $900?
 
1 - 13 of 13 Posts
Top