Polaris RZR Forum - RZR Forums.net banner

1 - 7 of 7 Posts

·
Milko
Joined
·
7 Posts
Discussion Starter #1
Hi guys im new around here i got a really big issue with the stationary sheave in the primary drive clutch, it just broke just the statonary it has a big crack from the center to the outside, and i wanted to know if someone have had the same problem and what could be the cause of this.
If anybody know something about this ill apreciate it very much.
 
H

·
Guest
Joined
·
0 Posts
Ive heard of a few cracking..never heard a definitive cause in any if the cases.
But..Is it a 2011? And are you running the stock 2011 belt? If so how many miles and has the primary ever been inspected for sheave wear? Reason I ask is they have changed to original belts..rumor has it because the compound was too hard and was causing the primary sheaves to wear excessively. I heard about this not long after I got mine and inspected the clutches and with only a hundred or so miles on it noticed a slight groove ( easily visible but could barely can feel it with my finger nail)worn into the primary stationary sheve near the center where the belt first contacts during engagement / low speed riding. I promptly changed the belt to the newer belt and the wear hasnt gotten noticeably worse.
If that happened to mine I'd call Team Industries and see if they'd would talk about it..they make the clutches..
 

·
Milko
Joined
·
7 Posts
Discussion Starter #3
Mine is a 2012 and i changed my belt for the first time at 80 miles, and now it have 200 miles, first time i checked for the wear and of course it didnt had any, till today i was checkin and cleaning my belt and found this crack on the sheave, what should i do? After i change the sheave of course, use another brand of belt?
Do i have to change the whole clutch assembly? I tried to look just for the sheave but the dont sell them alone.
 
H

·
Guest
Joined
·
0 Posts
Mine is a 2012 and i changed my belt for the first time at 80 miles, and now it have 200 miles, first time i checked for the wear and of course it didnt had any, till today i was checkin and cleaning my belt and found this crack on the sheave, what should i do? After i change the sheave of course, use another brand of belt?
Do i have to change the whole clutch assembly? I tried to look just for the sheave but the dont sell them alone.
Is it under warranty? If so obviously take it to a dealer..even if it's not I'd contact your dealer..unless there is some reason you know of that you haven't shared it has to be a defect..
 

·
Milko
Joined
·
7 Posts
Discussion Starter #5
Thats what i tought but the only problem is im in Panama, and i hate my dealer the only thing they are good at is selling the things, i called them today and they said to me that there wasnt any mechanic avaliable the last one, was gone and they were searching someone to replace him, this is so lame i dont trust them, thats why i decided to take the problem and solve it myself.
 
H

·
Guest
Joined
·
0 Posts
Thats what i tought but the only problem is im in Panama, and i hate my dealer the only thing they are good at is selling the things, i called them today and they said to me that there wasnt any mechanic avaliable the last one, was gone and they were searching someone to replace him, this is so lame i dont trust them, thats why i decided to take the problem and solve it myself.
Try calling Polaris direct..sadly that usually gets most no where but worth a try...ive actually had some success calling Polaris once in the past..if that doesnt work try calling Team Industries...they may be interested in the failure...can't hurt. Maybe Private Message JFK on here..he might be able to help you out.
If you just want to do it yourself as far as I know you'll need a to buy the clutch assy
 

·
Milko
Joined
·
7 Posts
Discussion Starter #7
I' ll try with team industries if a cant solve anything , ill have to buy the whole drive clutch , thank you very much for the info.
 
1 - 7 of 7 Posts
Top