Polaris RZR Forum - RZR Forums.net banner

1 - 16 of 16 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter #1
A while back I installed a stage 3 kit from aftermarket assassins. Initially I had it vent into the intake. I got a wild hair and decided to have it vent to atmosphere. I thought it would make a pssst noise but mine makes a whoooo noise. It's like a sick owl or a feeble Ric Flair sound. Is that normal? Anyone else have that issue?
 

·
Registered
Joined
·
1,254 Posts
mine was an evo blow off valve. VTA. It was quite loud. But was definitely the pshhhhhh Sound
 

·
Registered
Joined
·
45 Posts
Discussion Starter #4
Appreciate the replies. The write up on the bov was cool to read. In my case my biggest concern was I expected a good loud PSssst and instead got a lowly, sad sounding woo. I thought something was wrong with my aa bov. I'll probably end up rerouting it to dump to the intake. This isn't something I care all that much about to be honest. More curious than anything..
 

·
Aspiring Perfectionist
Joined
·
4,138 Posts
A while back I installed a stage 3 kit from aftermarket assassins. Initially I had it vent into the intake. I got a wild hair and decided to have it vent to atmosphere. I thought it would make a pssst noise but mine makes a whoooo noise. It's like a sick owl or a feeble Ric Flair sound. Is that normal? Anyone else have that issue?


That is the best description ever lmao. Spot on!

Whooo! Whooo!


-Give it a second... it had to go to space and back first ( Sent from the lifeline that is my iPhone XS Max )
 

·
Registered
Joined
·
831 Posts
I have that AA BOV that I initially ran, and it had a pretty sharp noise.... even if you decide to recirc I would unscrew that unit and check inside it.

Does it close up all the way under high boost at least? Because mine never did, which is why it’s not on the machine any more.
 

·
EE
Joined
·
152 Posts
FWIW I have the RKX based on RZR Joe's write-up, plumbed to recirc, and it sounds more like feeble Ric Flair than Psssht. I was actually wondering if I screwed something up on mine but the machine runs great with it, making boost where it should.



Ironically, I DID screw up initially and install it backwards, and heard absolutely ZERO sound at any point, but the machine still ran great?! I even have a data log file from that run that I had Mike look over and he said everything looked great.
 

·
Registered
Joined
·
45 Posts
Discussion Starter #11
I'll yank my AA valve out and take a look at it. I was thinking of installing another one just to see if it makes the noise I was expecting. (Not that I care about the pssst per se but it's what I was expecting) I appreciate all of the replies..
 

·
Aspiring Perfectionist
Joined
·
4,138 Posts
FWIW I have the RKX based on RZR Joe's write-up, plumbed to recirc, and it sounds more like feeble Ric Flair than Psssht. I was actually wondering if I screwed something up on mine but the machine runs great with it, making boost where it should.



Ironically, I DID screw up initially and install it backwards, and heard absolutely ZERO sound at any point, but the machine still ran great?! I even have a data log file from that run that I had Mike look over and he said everything looked great.


I don’t know if this applies to the OP and his AA BOV or not.... but I setup my RKX to vent to atmosphere after I read this thread because I was curious, sure enough, feeble Ric Flair was riding with me.... I only rode once like that, but I recently decided to adjust my wastegate so I could run the AA stage 3 tune I have if I wanted to.... I didn’t do it to get rid of the Nature Boy, but I found out, that it changed the BOV sound to the loud “psshhh” you would expect. This was the only thing I changed, Still currently on the same tune as before the adjustment, and that was the only thing in the entire intake/boost/engine I changed that could effect it.

My theory is that my wastegate wasn’t adjusted correctly to begin with, possibly due to my elevation (6000’) or just being tuned in general ( Even tho not a big enough tune to “require” an adjustment ), but I had always noticed (visually, by time/duration/shade of Turbo glow, even after the cat was removed ) that my Turbo was running hotter than I felt it should, because it was being a little overworked to maintain boost, because the wastegate was opening too soon, the feeble BOV sound was due to it partially venting out of the wastegate, and not holding the boost in the charge tube like it should, now that the wastegate doesn’t open as soon, the boost stays in the charge tube, like it should...so “pssshh!”

(Side note: I couldn’t remember where this post was, who was in it, or when it was really, so I found it by doing a forum search for “Ric Flair”.... which I found pretty hilarious )


-Give it a second... it had to go to space and back first ( Sent from the lifeline that is my iPhone XS Max )
 

·
Registered
Joined
·
45 Posts
Discussion Starter #13
I ended up replacing the as bov with the rkk setup and I am still getting the crappy whooo sound. I was planning on dumping back into the intake as I didn't have any idea what to do next. And didn't really want it spend a ton of time on it. But your post makes a lot of sense. I'll adjust the wastegate and see what happens. Thanks for posting that. Super appreciate it. Whooo.
 

·
Aspiring Perfectionist
Joined
·
4,138 Posts
I ended up replacing the as bov with the rkk setup and I am still getting the crappy whooo sound. I was planning on dumping back into the intake as I didn't have any idea what to do next. And didn't really want it spend a ton of time on it. But your post makes a lot of sense. I'll adjust the wastegate and see what happens. Thanks for posting that. Super appreciate it. Whooo.
Let me know if you have the same results I did, be nice to have another confirmation that it does solve the issue. I went a full 2 turns in on the wastegate rod, (shorter,used the AA video for guidance) just FYI. I also rigged it up with zip ties since i didn't have a mightyvac type tool (odd....i probably need one :grin), it worked out pretty good, it's a little tight in there, but not terrible.
 

·
Registered
Joined
·
45 Posts
Discussion Starter #16
I'm going to play with it tomorrow night. When I installed the stage 3 kit I adjusted the wastegate. I go a little further this time and post my results. A little more boost making it to the intake would be a plus. I just put 32s on it from 30s and I notice it even with the clutch weights adjusted to account for it.
 
1 - 16 of 16 Posts
Top