Polaris RZR Forum - RZR Forums.net banner

1 - 18 of 18 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have a 2012 rzrs with a blown motor has any one had any experiance with big bore kits if so what one I have looked at the muzzys kit it looks like a potential option .also I have been considering a Turbo or a supper charger any input would be apreaciated
 

·
Registered
Joined
·
370 Posts
I don't have an answer for you, but i'm also thinking of the muzzy BBK. On a side note, How did you blow the motor?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Its still ln the shop they say I got dirt into the case which caused the oil pump to fail but due to a after market air filter Polaris has rejected warranty . I'm not so sure that is really the truth
 

·
Registered
Joined
·
500 Posts
i had a holz stage 3 big bore kit in my 2012 rzr s. It worked great.
 

·
Registered
Joined
·
370 Posts
That sucks.....How did dirt get from the intake into the crank case? Did you leave the breather disconnected?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
Like I said I don't believe that's what happened .But that's what Polaris said happened I'm going in on wed to look over the damage for my self . I think I would have noticed that much dirt or mud in the intake tube while servicing the air filter
 

·
Registered
Joined
·
370 Posts
Make them prove how the intake allowed dirt into the crankcase. I would think you would have major ring or valve seal failure before the oil pump would fail. The only way i could see is if the breather hose was left disconnected. Good Luck.
 

·
Registered
Joined
·
1,485 Posts
i had a holz stage 3 big bore kit in my 2012 rzr s. It worked great.
How/Who sold you a Holz stage 3 bigbore kit for a 2012 model. tried and was told their kits was for/only fit 2008-2010 models. since slight change head at intake manifold/injectors, different T.B., intake has sensors in it, block has cam position sensor in it on 2011-12 models.
 

·
Premium Member
Joined
·
41,100 Posts
Its still ln the shop they say I got dirt into the case which caused the oil pump to fail but due to a after market air filter Polaris has rejected warranty . I'm not so sure that is really the truth


It's BS... You must have had a ton of dirt in the engine for the oil pump to fail... I'd ask for the oil pump and have a independent shop check to see if it failed...

Racer Sam had the most dirt (clods) in a engine that I've ever seen and his oil pump didn't fail... Pictures are here on the forum of his dirt ingestion...
 

·
Registered
Joined
·
27 Posts
My 2010 s threw a connecting rod and vented the block early this summer (800 easy miles), I researched the prices for a stock polaris 800, and also the option of buying parts to build a big bore. In the end I chose to ditch the factory JUNK!
I'm in the process of installing a weber 750 out of a 2007 polaris switchback, buy a wrecked 4-stroke polaris skidoo and swap it yourself, in the end i bet you'll come in a little higher price wise than a big bore and turbo, But you'll have 150 (RELIABLE) hp. Just my 2 cents
 

·
Registered
Joined
·
127 Posts
I also have a Trinity Racing big bore with a turbo. I have had it on the sand for just about a full season now and it has ran really well. I have had it from 11-13 lbs and it hasn't missed a beat. I did the 82mm bore (true 800), ARP studs, JE 8.5:1 pistons, and the Hot Rod race crank. The kit came with the gaskets also.
 

·
Registered
Joined
·
8 Posts
OK I blew a rod bearing on stock motor so I now have completely rebuilt the motor. 876cc big jug kit, ported but not polished as i heard that was a bad thing, billet crank, 12:1 pistons (im getting 215psi and its only got and hour on it)!! new racing cam, roller lifters, roller rockers, dual valve springs, billet intake, new valves and guides and seats, pushrods, powercomander v, o2 sensor to a gauge and adjusting the fuel and timing with laptop as i drive around. still waiting on throttle body and exhaust. I was expecting this thing to wheely off the line but i have only a little more low end power and no more top end power?!?! Im hoping the exaust and throttle body is whats holding it back. I was also expecting to have to add more fuel but according to my o2 sensor it wants me to minus fuel!!!!! I dont understand. and playing with the timing, i thought at idle the timing was 13 deg, i have moved the timimg as far as 14 degrees advanced than stock which would would put my ignition point 1 degrees before tdc but it likes it!!! again i dont understand i was expecting it to knock or ping when i did that. unless i am wrong about the stock timing or something. IDK this is supposed to be a 100 hp motor i was hoping but its not there. Any ideas?
 

·
Registered
Joined
·
2,396 Posts
I have a 2012 rzrs with a blown motor has any one had any experiance with big bore kits if so what one I have looked at the muzzys kit it looks like a potential option .also I have been considering a Turbo or a supper charger any input would be apreaciated
Call Matt at Holz Racing, if you haven't yet. He ships to Canada. Others have bigger cc's maybe but Holz have a very proven product. Strong engine and very reliable. Matt is a no Bull Shyt, no nonsence type of guy and is very helpful. Swingarm (Tim) on the forum sells them but does not ship to Canada as far as I know. My 2 cents.
Ken
 

·
Registered
Joined
·
22 Posts
i blew my motor in mrzr 800s. after all my research it was more cost effective to build a big bore stroker motor. i had redline racing build it and it was only about 3k more then buying a new stock motor. could not be happier with the build. its a muzzys big bore kit
 

·
Registered
Joined
·
27 Posts
i blew my motor in mrzr 800s. after all my research it was more cost effective to build a big bore stroker motor. i had redline racing build it and it was only about 3k more then buying a new stock motor. could not be happier with the build. its a muzzys big bore kit
Did it come with or did you add clutch kit new spark plugs and ignition?
 
1 - 18 of 18 Posts
Top