Polaris RZR Forum - RZR Forums.net banner

1 - 11 of 11 Posts

·
Registered
Joined
·
736 Posts
Discussion Starter #1
I have a 2008 polaris RZR. i have owned it almost 2 weeks now. went out for the first time put it in AWD to climb a hill and realized that it wasnt locking into awd at all and my back tires were spinning. so then i read the front diff forum and found out a lil info. ive checked the ohms and they r fine and ive checked the volts and they are great. heres what its doing. i jacked up all 4 wheels and put in into high gear. got it going about 40 with the AWD switch on showing its on in the display. itll drive without being engaged and then will suddenly engage and then disengage whenever it pleases. so where should i start. any ideas on what might be wrong. im thinking the roller cage but the guy before me just replaced it about 2 months ago. so im looking at pulling out the front diff. now heres what im wandering. if i take out the front diff, the cv shafts can i shill drive it? do i need to take out the front drive shaft also? i have a few trips setup that i wont need AWD and dont wanna miss it but i wanna get it out and torn apart and order the parts i need to fix it. if someone could give me input on if i can still drive and what all i need to take off to be able to drive it. please everyone give me some input.
 

·
Registered
Joined
·
880 Posts
Wow, you read all 12 pages.......I take it you've checked the fluid, what kind of fluid is in there?
 

·
Banned
Joined
·
1,182 Posts
Remember it is AWD not FWD and many times the front won't engage until the back is slipping enough to transfer power to the front! It the Carrier in the front is broke it will make a big clicking noise in the front dif! The fluid level is important for the solenoid to work right! If the power is right then you might have to pull it and check to see if it is working? But I would put it on jacks with the AWD engaged in Neutral on the tranny and see if you can turn by hand the front wheels and see if the back will turn or the opposite wheel, that might tell you the front is locked, but moving the back without resistance won't do anything! Good luck!
 

·
Registered
Joined
·
736 Posts
Discussion Starter #4
I had my buddies and tried the same thing with jacking all the wheels off and it engaged immediately. Mine will engage after awhile but it makes a loud grinding clunking noise and it will disengage and reengage whenever it pleases. I'm running Polaris fluid and it's filled. Now does that sound like something in the inside is broke prolly a cage or something?

Also ya I read all 12 pages a few times while I was at work lol
 

·
Registered
Joined
·
2,516 Posts
Is the awd indicator light going on and off on the dash? I had trouble with mine a few months ago. It took a lot of flipping back and forth to go in awd and would come out of it on its on. I remembered the water i had gone through that spashed up over the dash a week before. My headlights also quit working. Those switches aren't waterproof. Both of mine were corroded and not making contact. I took them apart, cleaned them up, everything works fine now.
 

·
Registered
Joined
·
736 Posts
Discussion Starter #6
well i took my buddys switch out of his and it worked perfect on his everytime we engaged it. so i used to switch to check it and it worked. the only thing that concerns me is i can engage it and put it into neutral and turn the left front wheel and the right one wont turn or the rear ones wont turn either. so its nto engaging in the diff. im just stumped and about to rebuild the front diff with a new cage and plate and seals
 

·
Registered
Joined
·
62 Posts
is your h as in high gear indicator light on? is so it will not engage the awd function if it is on your switch might be bad my switch went out replaced and ok.
 

·
Registered
Joined
·
880 Posts
well i took my buddys switch out of his and it worked perfect on his everytime we engaged it. so i used to switch to check it and it worked. the only thing that concerns me is i can engage it and put it into neutral and turn the left front wheel and the right one wont turn or the rear ones wont turn either. so its nto engaging in the diff. im just stumped and about to rebuild the front diff with a new cage and plate and seals
I believe part of the criteria for engagement is you must be in gear, replace the switch and go ride!
....update.... so you were saying your switch worked in your buddys ride, right!
 

·
Registered
Joined
·
736 Posts
Discussion Starter #11
Ya tried it on my buddies and it worked fine everything I have yet works on my
Buddies but mine doesn't. It'll engage when I kit like 40 mph and it'll clunk and grind when it engages but it won't stay engaged. It's not the switch and I know the rear wheels has to lose traction before it kicks in
 
1 - 11 of 11 Posts
Top