Polaris RZR Forum - RZR Forums.net banner

1 - 10 of 10 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter #1
took the rzr out for a rip on the weekend and the primary absolutely grenaded. took the secondary out also. anyone else have issues like this or know what would cause it? machine only had 1500 miles on it. 2014 XP1K
77070120_446207232750894_1949437504776044544_n.jpg
 

·
Standard Vendor
Joined
·
1,440 Posts
Looks like it's never been looked at, cleaned or inspected so 1500 miles is pretty good. Time to start over!
Regards,
 

·
Registered
Joined
·
33 Posts
Discussion Starter #3
Looks like it's never been looked at, cleaned or inspected so 1500 miles is pretty good. Time to start over!
Regards,
they were inspected every few rides, maybe not fully cleaned but not my first CVT machine and never had this happen to any clutch (rzr/quad/sleds etc)
 

·
Standard Vendor
Joined
·
1,440 Posts
Not trying to be disrespectful, Iv'e just never seen a drive so black/ discolored. Common problems are flat spotted rollers on secondary, seized bearing on primary. The drives can get sticky from dirt, dust and rubber dust from the belt and they won't work right. We have seen the internals on the secondary explode, springs break, rollers fail etc.... Again 1500 miles isn't bad.
Regards,
 

·
Registered
Joined
·
33 Posts
Discussion Starter #5
guess i was just surprised and expected more out of them. my 900 had was more miles, driven a lot harder and got less maintence and never had an issue with it haha
 

·
Registered
Joined
·
1,988 Posts
I've put about 1500 miles on mine, and about 1000 of those have been boosted with anywhere between 10 - 22 psi! They are still pretty solid. They do get taken off often to recutch based on the dunes and high boost or trails and heavy 32s.

Sent from my SM-G892A using Tapatalk
 

·
Registered
Joined
·
92 Posts
I bet you had something stuck in your primary that caused your belt to wear out the outer sheave half. Or the shaft alignment is way off. On my 14 i would get about 3000 miles out of the primary then it was warm out and things like the rollers would be gone.
 

·
Registered
Joined
·
34 Posts
Got 7100 miles from my stock 2015 clutch. Constant cleaning. Had a buddies blow apart like your picture. Clutch was hot and he ran through water that got inside the housing. Bang it was in pieces.

Sent from my SM-G965U using Tapatalk
 

·
Registered
Joined
·
33 Posts
Discussion Starter #9
probably needs more cleaning i guess haha. oh well, the deed is done and new clutches have been purchased. onwards and upwards
 

·
Registered
Joined
·
23 Posts
How often are you guys cleaning the CVT? Just asking as I just picked up my first RZR, been riding Yamaha and Honda for years.
 
1 - 10 of 10 Posts
Top