Polaris RZR Forum - RZR Forums.net banner

1 - 6 of 6 Posts

·
Registered
Joined
·
222 Posts
Discussion Starter #1
Hey guys, has anyone had a problem with there RZR (after fireing) which is like back fireing according the dealer. I rode about 47 miles yestarday about 2 miles from the truck it happened. The terrain was only alot of sand trails and alot of berms so the riding was not very fast paced. It wasnt really dusty because of the rain the night before. The dealer told me that could happen to any RZR because of the way I was riding the RZR. On the throttle and off the throttle alot and usually average around 10-15 mph. So its nothing like riding in the MTNS with rocks, hills, mudd etc. which is mostly the type of riding I do. So any input would be Great!!!!

Anthony
 

·
Registered
Joined
·
2,511 Posts
i've never had it happen yet but we'll see. sounds like raw fuel in the exhaust igniting right? it could happen. i know mine runs extremely rich when i'm doing a lot of slow trail riding/mud.
 

·
Registered
Joined
·
75 Posts
Now that you mention it, it happened to me the last time I went to the dunes. It was the 1st time it had happend, and it hasn't happend again, but it worried me at the time. I'm currious about it myself.

More specifically, it happend after reaching the top of a steep but short dune. Let off the gas at the top and POP! It may have even shutt down after that and had to crank longer than usual to ger her going again. Kind of hard to remember. Too many brain cells...
 

·
Registered
Joined
·
222 Posts
Discussion Starter #5
Just curious if running without the Spark Arrestor would cause it do After Fire. I took mine out when I went to Brimstone in May and thats when my TPS went bad. I have had a new one put in so this is the first time that I've rode since the new TPS. The dealer in Knoxville TN told me that running a UNI Filter could have caused the TPS to go bad because of the Oil on the filter. So if anybody has any input please let me know.

Thanks Anthony
 

·
Registered
Joined
·
9 Posts
i have a 09 rzr it never did it at all untill I installed snorkels, if I run hard down the road and let off to coast to the corners, it has multiple back fies, and have even had a buddy following me once and he staded that it has like a constant lit torch at the tailpipe when i let off the gas, it is obviously raw fuel building up in the pipe, and with long hard runs the pipe gets so hot that when letting off the back pressure sucs a bit offres air back and poof it lites.. It was worse when I had a bad exhaust seal, got better whe it was replaced, it got even better when I changed my airbox snorkel to a 3" from a 2". iM SURE THAT ONE OF THESE DAYS ITS GONNA BLOW THE END OFF THE MUFFLER LOL!!!
 
1 - 6 of 6 Posts
Top