Polaris RZR Forum - RZR Forums.net banner
1 - 13 of 13 Posts

·
Registered
Joined
·
78 Posts
Discussion Starter · #1 ·
Anyone install the AA S2 clutch kit and find it hard to get into gear? I'm wondering if I over torqued the primary and secondary and it is causing misalignment? I did not torque to spec when I installed, guessing that might be my problem? When I do get it in gear, at idle it is wanting to move, so I'm guessing the clutch is trying to engage...
 

·
Registered
2021 xp turbo4
Joined
·
934 Posts
Would it be as easy as backing the bolts off and torquing or should I pop the primary completely off and then torque to spec?
What year Turbo s? If its 2021 you shouldn't have to completely remove the primary. Im not really familiar with the old style. If you completely removed the primary when installing, I would remove everything again and torque everything to spec. I'd make sure the hardware is still in good shape and possibly replace if you think you over- tightened.
 

·
Registered
Joined
·
78 Posts
Discussion Starter · #9 ·
What year Turbo s? If its 2021 you shouldn't have to completely remove the primary. Im not really familiar with the old style. If you completely removed the primary when installing, I would remove everything again and torque everything to spec. I'd make sure the hardware is still in good shape and possibly replace if you think you over- tightened.
2019 2 seater. I might try the easy way first, back out the bolts and torque to spec. If that doesn't fix, I'll take it completely apart, back everything off, torque to spec and reinstall.
 

·
Registered
Joined
·
1,199 Posts
2019 2 seater. I might try the easy way first, back out the bolts and torque to spec. If that doesn't fix, I'll take it completely apart, back everything off, torque to spec and reinstall.
If you didn’t remove primary throw the torque spec idea out the window. Did you install their stupid snap ring delete kit on the secondary?
 

·
Registered
Joined
·
78 Posts
Discussion Starter · #11 ·
If you didn’t remove primary throw the torque spec idea out the window. Did you install their stupid snap ring delete kit on the secondary?
I completely removed the primary and secondary when i installed the weights and springs.I cleaned up all of it and scotch brite the surfaces as well. Mine did not have a snap ring on it when I removed the secondary. I bought this used a few years ago, not sure if the previous owner did a snap ring delete or if this year and model did not have one.
 

·
Registered
Joined
·
1,199 Posts
I completely removed the primary and secondary when i installed the weights and springs.I cleaned up all of it and scotch brite the surfaces as well. Mine did not have a snap ring on it when I removed the secondary. I bought this used a few years ago, not sure if the previous owner did a snap ring delete or if this year and model did not have one.
Then if you removed primary re torque it. Sometimes you have to go a few extra foot pounds to get it just right. Secondary should have a big black spacer on the outside of it that the bolt goes through. If there’s a stack of washers there order the right oem washers for it
 
1 - 13 of 13 Posts
Top