Polaris RZR Forum - RZR Forums.net banner

1 - 10 of 10 Posts

·
Registered
Joined
·
66 Posts
Discussion Starter #1
I'm rebuilding a salvage 900s. The motor starts with throttle and will run under throttle, but it will not idle or start without throttle. I was able to get it to idle at 2k+ rpms for a bit this weekend. I realize that's too high, but it did run on its own.

I've checked valves and timing. Seems to be in spec here.





.


What should I check next? Compression?
 

·
Registered
Joined
·
46 Posts
Check the throttle body calibration and gas pedal calibration if they are off the butterfly on the throttle body will not open enough to keep the engine running. Did you replace either of the two components


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
66 Posts
Discussion Starter #3
Thanks Danny. I was pulling the entire intake tonight and found one of the adapters leading into the cylinder from the intake manifold was cracked. I'm thinking this is my issue. I've ordered the part to replace it and hopefully I'll have it by this weekend to test.

 

·
Registered
Joined
·
2 Posts
I’d be interested in knowing what happened here my 2013 rzr 900xp is doing this too plus I have an aftermarket turbo with oil in the intercooler I’m not sure what to check
 

·
Registered
Joined
·
66 Posts
Discussion Starter #7
The rubber gasket I posted was the issue. It had a crack in it and non-metered air was entering the intake.
If your engine won't idle but runs, check your intake and see if you have any leaks. I didn't see my issue until I took the entire top end apart.
 

·
Registered
Joined
·
1 Posts
Check the throttle body calibration and gas pedal calibration if they are off the butterfly on the throttle body will not open enough to keep the engine running. Did you replace either of the two components

Sent from my iPhone using Tapatalk
I’ve got a 2015 it’s hard to start like it’s starving for fuel but as long as you keep your foot on the gas it’ll run but once you take it off it dies will not idle? An at top end it shuts off like the pump is bad could the fuel pump cause this?
 

·
Registered
Joined
·
170 Posts
I’ve got a 2015 it’s hard to start like it’s starving for fuel but as long as you keep your foot on the gas it’ll run but once you take it off it dies will not idle? An at top end it shuts off like the pump is bad could the fuel pump cause this?
That sounds like intake valves need adjusted. let it warm up and if it runs better than you need to adjust the valves. Intake valves get tighter over time, eventually they never let the valves fully close and you notice it first with hard starts. Not to difficult to check, there are YouTube vids on it.
 
1 - 10 of 10 Posts
Top