Polaris RZR Forum - RZR Forums.net banner
1 - 20 of 24 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter · #1 ·
Went through some water this weekend, oil dipstick was not locked down. Did not know I had water in my crankcase. I took off didnt make it hundred yards and it shutdown. Thats when I found dipstick was up. Immediately drained oil and refilled. Pulled bed and sparkplugs no water on top of pistons. Acted like it was slow to turnover would not fire. Drained oil again and refilled. Turned over at normal speed and alot faster without plugs. Still will not fire, im getting spark and gas. Not real sure about compression yet. Its sucking in and air is coming out of exhaust. Why will it not fire?

Sent from my SAMSUNG-SGH-I747 using Tapatalk 2
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #6 ·
No I have not but just tried to plug it with my thumb and it didnt even blow my thumb off. May not be a good way to check but it dont seem good. Sounds like ill need a rebuild. Ill get a true check before I pull the engine. Top and bottom more than likely being that my bottom end got the worst of it. Just wish it would of come in through my air box. I believe water sitting on top of my piston would of stopped it before too much damage done.
So what are my best options? Find used engine or rebuild? Big bore kit? Reliable? Try to sell blowed up and buy a new one? Ha

Sent from my SAMSUNG-SGH-I747 using Tapatalk 2
 

·
Registered
Joined
·
1,120 Posts
It is hard to believe that so much happened in such a short distance. I would think if you filled the lower end with water you would not know it until the dirty water ate the bearings and camshafts up. How many RPM's were you running going thru the water?

If water got on top of the pistons then it could have bent a rod thus causing the damage so quickly.

If it is not at least trying to blow your finger away from the spark plug hole an engine tear down is going to have to happen.
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #9 ·
Man I got out of the water ran down the road a lil ways at pretty high rpms... didnt show any signs i had any water until it shutdown. It didnt have on top of pistons. My first thought was i schorched a bearing being it was hard to turnover but it let loose after i put new oil in it. But i just checked my compression it has 0 in one and 90 in the other rings are gone im guessing. Im thinking it filled up with water and blew my rings out and screwed bottom end up as well. I dont know too much about these engines.

Sent from my SAMSUNG-SGH-I747 using Tapatalk 2
 

·
Registered
Joined
·
1,120 Posts
That sure does bite. All you can do is tear down and see whats happening. I used to like to play in the water but have gotten out of that racket. Costs too much money to play and always cleaning mud out of everything. Now days I will go around or go back the way I came from.

How about insurance claim?? If you can't do the work yourself it will be a pretty good sized bill for the parts and labor.

I see you are from cornith, MS. I bought a 800 sportsman from the local polaris dealer back in 2006. Can't remember their name right off the top of my head. They had a way better price than any of the dealers around my neck of the woods. The dealers around here told me they did not know how they could sell them at that price. Did you get your ride from them?
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #11 ·
Yea I did they are some good folks to deal with. They will work with ya best they can. I think I put some voodoo on myself Friday. I went in there and mentioned trading it in while I was buying oil and filter.

I'm going to do some research. Ive been told a used engine may not be that hard to come by and not too bad expensive. Im going to pull it and crack it open and see what all I got going on.

Im just going to cut my losses and buy and build as I can. Between work and deer season right round the corner its going to be tough.

How much is a blowed up lifted rzr worth? Lol.

Sent from my SAMSUNG-SGH-I747 using Tapatalk 2
 

·
Banned
Joined
·
62 Posts
stay away from utvengine rebuilders and keith, worst place i ever done business with, gave me a phone quote on my ebay rebuilt rzr 800 motor then wouldnt honor it, wouldnt give my motor back either, keith is very rude and thinks he doesnt need to stand behind what he says b/c basically all he canpoint out is that i used a empty milk jug to pack my motor. he says he has never had a problem in 10 years yet he has an attorney on retainer, also complaints in bbb and the ags offices he always ignores, they are not some one you want to trust, especially selling a warranty and not bbb accredited and ignore 3rd party agencies.
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #13 ·
Aight got head off and cylinders. Everything looks brand new! Rings are not broke. At this point from what i can tell the cam lobes look good too. Why didnt I have compression?

I do know I have a rod bearing that is spun or gauded how ever u want to put it. One rod will move freely on the crankshaft and the other one will not its actually wants to move the crank its so bad, makes me think my mains are good. Whats the chances I can just get new bearings and not a crank?

But thats not going to help me fix my compression issue. Please any help will be much appreciated.



Sent from my SAMSUNG-SGH-I747 using Tapatalk 2
 

·
Registered
Joined
·
1,120 Posts
How about some pictures??

I don't know if you can get these cranks turned and buy undersized bearings. What does a crank cost? A automotive machine shop might be able to polish the crank. I would fix it right. I would hate to take a chance on it.

Not sure on the compression or lack of. Did the engine not try to blow your finger out on both cylinders or only one of them??
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #15 ·
I checked compression...it wouldnt register on one and only had like 60 on the other.

I work at a cat reman plant, thats why I was curious about that. But im down to fix it right.

I just wish I would of turned the crank some how while I had the head on with rocker arms and push rods working. I did notice my valves were all the same level when I took valve cover off. All were closed. I found that to be strange. (May be normal).

Sent from my SAMSUNG-SGH-I747 using Tapatalk 2
 

·
Registered
Joined
·
1,120 Posts
Even if the lifters are hydraulic adjusted they should still push the valve open without oil pressure. Meaning I think you may have camshaft or lifter problems as well. I have not torn one of these engines apart, just thinking like you that at least one should have been open.
 

·
Premium Member
Joined
·
41,099 Posts
I have these kits in stock ready to ship, this takes the guessing and time wasted waiting for your dealer to order the parts...These are OEM Polaris Parts for the RZR, RZR S and RZR 4 "800" Engines...


1) Head Gasket (1) $30.00
2) Base Gasket (1) $20.00
3) Mag / Access Gasket (1) $18.00
4) Oil / Water Pump (1) $115.00
5) Oil Pickup Tube (1) $22.00
6) Oil Shaft Seal (1) $28.00
7) Seal (1) $21.00
8) Seal (1) $13.00
9) Water Pump Seal (1) $40.00
10) Main Bearings (2) $40.00
11) Counter Balancer Bearings (4) $75.00
12) Pistons, Rings Wrist Pins and Cir-Clips (2 sets) $199.00
13) Oil (2 qts) $20.00
14) Oil Filter (1) $10.00
15) Dowel Pin (1) $5.00
16) Spring (1) $5.00
17) Spark Plugs (2) $12.00
18) Lifters (4) $40.00
19) Push Rods (4) $88.00
20) Cylinder (1) $300.00
21) UTVINC Billet Breather (1) $40.00
22) Crank (1) Cost Depends on OEM or Aftermarket
23) Valve Job (Cost Depends on Parts required)


Pick and choose your parts...

Total Of Parts PLUS Shipping to the lower 48 States...
 

·
Premium Member
Joined
·
41,099 Posts
How about some pictures??

I don't know if you can get these cranks turned and buy undersized bearings. What does a crank cost? A automotive machine shop might be able to polish the crank. I would fix it right. I would hate to take a chance on it.

Not sure on the compression or lack of. Did the engine not try to blow your finger out on both cylinders or only one of them??
Cranks are non rebuild-able (throw away cranks)... Fact not Fiction...
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #20 ·
I sprayed a lot of wd 40 on top of my head to see if it would leak through couldnt tell that it did. I understand its not the best way to check. Maybe ill discover a lil more this afternoon when I crack the bottom end open. May be a cam and lifter issue is the only thing I can think of and thats where all the water and sand was. Unless I broke the gear off the cam somehow. Heck I dunno!! So much to troubleshoot when nothing jumps out at you.

Sent from my SAMSUNG-SGH-I747 using Tapatalk 2
 
1 - 20 of 24 Posts
Top