Polaris RZR Forum - RZR Forums.net banner
1 - 9 of 9 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
2021 RZR XP1000 Sport. It’s one year and one month old.
Please watch video and give me some advice.
The battery stays on battery tender.
I removed ground wires, cleaned and applied grease. They were loose.
I took the battery to Advance and it showed good. He tested it twice.
I really don’t want to throw parts at it and hope someone had the same problem.
Thanks for any help.
 

·
Registered
Joined
·
745 Posts
Haven't had that problem but my 2¢ anyway 'cuz no replies here so far and I know how that feels.

If it were me, I'd check all the ground wires - there are a few of them - happy hunting. I'd also be checking the connections to the starter.
 

·
Registered
Joined
·
237 Posts
2021 RZR XP1000 Sport. It’s one year and one month old.
Please watch video and give me some advice.
The battery stays on battery tender.
I removed ground wires, cleaned and applied grease. They were loose.
I took the battery to Advance and it showed good. He tested it twice.
I really don’t want to throw parts at it and hope someone had the same problem.
Thanks for any help.
Brake switch could be loose , or bad connection.
 

·
Standard Vendor
Joined
·
1,562 Posts
Ok, here are some dumb stuff to look for.... Ignition switches can be or go bad, double check that the harness plug is installed completely. Then try it with your spare key to see if anything changes. As for the brake switch, I had a Ace 900 that was a little touchy and really had to depress the brake pedal firmly before it would crank right. Hope you find the problem.....
Regards,
 

·
Registered
'18 XPT
Joined
·
2,454 Posts
It would be interesting to see a volt meter on the starter wires when trying to start it..
 

·
Registered
Joined
·
517 Posts
Easy way to check the brake sensor is to disconnect and jumper it to see if it starts fine. Or hold the brake and have someone else see if the brake lights come/stay on while cranking.

Just have to go through the starting circuit and test each component to see if you can find it.
 

·
Registered
Joined
·
68 Posts
My 2020 TRE just started doing the same thing if i turn my ignition switch all the way to the right its does it.
I just turn it slowly and it starts every time .
I believe its in the ignition switch . im going to order a new one soon .
 

·
Standard Vendor
Joined
·
1,562 Posts
Great news..... Glad it worked out for you. Time to ride!
Regards,
 
1 - 9 of 9 Posts
Top