Polaris RZR Forum - RZR Forums.net banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1 (Edited)
I just bought a new RZR 900 trail Fox edition. I took it off the trailer today and only put ,less than, a couple of miles on it.
I don't think I even made it over 15 mph. On the top of the ride command, there is a red engine icon on. It also has an orange stearing wheel with an exclamation point next to it.
Does anyone know what these mean ? I looked in both of my manuals and saw no reference to it.
Thanks
646189
 

·
Registered
Joined
·
2 Posts
I am new to the forum, just bought a used 2019 last weekend, so know very little about this stuff yet. I might know this one though.

I do not have ride command, but those same icons were popping up on the dash while at the dealership. Asked a mechanic, and he said something to the effect of the key being left on while it isn't running, will make it think it has some steering issues. Can't remember exactly what he was explaining, but said if you turn it off for a few seconds, then start it, it will go away.
 

·
Registered
Joined
·
443 Posts
I am new to the forum, just bought a used 2019 last weekend, so know very little about this stuff yet. I might know this one though.

I do not have ride command, but those same icons were popping up on the dash while at the dealership. Asked a mechanic, and he said something to the effect of the key being left on while it isn't running, will make it think it has some steering issues. Can't remember exactly what he was explaining, but said if you turn it off for a few seconds, then start it, it will go away.
The power steering unit on EPS models is electric and takes quite a bit of juice to run. Its a built-in safety feature that disables the power steering if your key position is "On" but the engine isn't running (AKA Accessory mode). This prevents your battery from draining to a point where it won't start and possibly leave you stranded in the middle of nowhere. I've done this on purpose many times (left ignition "On", let the EPS disable and start it up so I can drive around and see what it would be like without EPS. To reset it all you need to do is turn the key position to off. Next time you start it, it should be gone.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
The power steering unit on EPS models is electric and takes quite a bit of juice to run. Its a built-in safety feature that disables the power steering if your key position is "On" but the engine isn't running (AKA Accessory mode). This prevents your battery from draining to a point where it won't start and possibly leave you stranded in the middle of nowhere. I've done this on purpose many times (left ignition "On", let the EPS disable and start it up so I can drive around and see what it would be like without EPS. To reset it all you need to do is turn the key position to off. Next time you start it, it should be gone.
Thanks for the input ! After playing with the ride command a bit, I found the engine codes. The code said "Vehicle speed signal is intermittent or missing"
I called the dealership and they had me check the speed sensor connection on the passenger side above the rear differential. I unplugged it, it was dry and looked ok, I pluged it back in and took it for a test ride. All warnings disappeared !!! Drove it all day, no more issues.
Thanks for your reply !!
 

·
Registered
Joined
·
443 Posts
Thanks for the input ! After playing with the ride command a bit, I found the engine codes. The code said "Vehicle speed signal is intermittent or missing"
I called the dealership and they had me check the speed sensor connection on the passenger side above the rear differential. I unplugged it, it was dry and looked ok, I pluged it back in and took it for a test ride. All warnings disappeared !!! Drove it all day, no more issues.
Thanks for your reply !!
Good deal!


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
5 Posts
I just bought a new RZR 900 trail Fox edition. I took it off the trailer today and only put ,less than, a couple of miles on it.
I don't think I even made it over 15 mph. On the top of the ride command, there is a red engine icon on. It also has an orange stearing wheel with an exclamation point next to it.
Does anyone know what these mean ? I looked in both of my manuals and saw no reference to it.
Thanks
View attachment 646189
 

·
Registered
Joined
·
5 Posts
Code:
without seatbelt on only driver won't do over 15 the steering  is if you leave key on the on position  without  starting  it shuts epas off electric power steering go to all settings  vie

vehicle  diagnostics  it will  tell you what's going on not fully but if you know you will figure it
 
1 - 7 of 7 Posts
Top