Polaris RZR Forum - RZR Forums.net banner

1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Help with power steering issue. The machine is 3 years old but only has 160 miles on it. The code 520230 shows and I have NO. Power steering. I have checked everything I can find on these forums to check and nothing has worked. Help!!!! Lol.
 

·
Registered
Joined
·
681 Posts
Have you checked the fuse? Check the relays? I have the same model and mine kept blowing the fuse. I ended up having a bad voltage regulator and had to replace it.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
I haven't yet. I will today. I bought a new battery and drove it around for a bit. EPS light still on. No power steering. I'll check all the fuses tonight. And get back to ya. Thanks.
 

·
Registered
Joined
·
59 Posts
I haven't yet. I will today. I bought a new battery and drove it around for a bit. EPS light still on. No power steering. I'll check all the fuses tonight. And get back to ya. Thanks.
There’s only one fuse that would cause it and that’s the EPS fuse, mines a 20A fuse. I blew it last week and had this issue. Luckily there was a spare in my block to replace and go
 

·
Premium Member
Joined
·
7,620 Posts
New battery? Just throwing parts at it? Google the code.
"IC CAN communication error with EPS"
Sounds like a wiring or EPS problem; might be fuse...
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Alrighty. Best case scenario for now. It was the fuse. Prolly needed a new battery anyway tho. Lol. It was 3 years old. Thanks for the help. I'll keep some extra fuses on me in case it happens again. If it recurs. I'll check the regulator next. ??
 

·
Registered
Joined
·
681 Posts
Good deal. My voltage regulator issue was easy to diagnose, at idle you could watch the Volts go from 12.2 to 17.1 back and forth. Hope you don't have to replace it too.
 
1 - 7 of 7 Posts
Top